summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2020-01-22 21:39:40 +0800
committerAllen Zhong2020-01-22 21:40:02 +0800
commit46e4ecfeca0669913490d09aa692f0917b5da0ee (patch)
tree7aa686501b16a64c24fbb56993db7378a32ed120
parentfeb745a799a1f32a6ba963401e181ac308cd5492 (diff)
downloadaur-46e4ecfeca0669913490d09aa692f0917b5da0ee.tar.gz
Bump to version 3.0.9
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD10
3 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 093dff0e8481..c93260e40b2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tikv-pd
pkgdesc = Manage and schedule the TiKV cluster.
- pkgver = 3.0.0
+ pkgver = 3.0.9
pkgrel = 1
url = https://github.com/pingcap/pd
arch = x86_64
@@ -10,12 +10,12 @@ pkgbase = tikv-pd
makedepends = git
provides = pd-server
backup = etc/pd/pd.toml
- source = pd-3.0.0.tar.gz::https://github.com/pingcap/pd/archive/v3.0.0.tar.gz
+ source = pd-3.0.9.tar.gz::https://github.com/pingcap/pd/archive/v3.0.9.tar.gz
source = pd.service
source = pd-sysusers.conf
source = pd-tmpfiles.conf
source = pd.toml
- sha256sums = 090f3876a45165441d11fa54958beed89f88b3818ef0144ff374685801e9bff0
+ sha256sums = fbe73c34c37d23bd07e44162ac766758debc25fedde7514c9545d53c848bbd69
sha256sums = b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924
sha256sums = 5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67
sha256sums = 15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495
diff --git a/.gitignore b/.gitignore
index 2a4661c1b5a5..f3a9520f03ab 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
*.tar
*.gz
*.xz
+*.zst
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 57dcc2a7840c..76d161390a19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
+# Maintainer: Allen Zhong <zhongbenli@pingcap.com>
pkgname=tikv-pd
-pkgver=3.0.0
+pkgver=3.0.9
pkgrel=1
pkgdesc='Manage and schedule the TiKV cluster.'
makedepends=('go' 'make' 'git')
@@ -14,7 +15,7 @@ source=(pd-${pkgver}.tar.gz::https://github.com/pingcap/pd/archive/v${pkgver}.ta
pd-sysusers.conf
pd-tmpfiles.conf
pd.toml)
-sha256sums=('090f3876a45165441d11fa54958beed89f88b3818ef0144ff374685801e9bff0'
+sha256sums=('fbe73c34c37d23bd07e44162ac766758debc25fedde7514c9545d53c848bbd69'
'b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924'
'5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67'
'15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495'
@@ -34,10 +35,11 @@ build() {
export PATH=$GOPATH/bin:$PATH
export CGO_ENABLED=0
- _LDFLAGS="-X $_gopkgname/server.PDReleaseVersion=$pkgver -X $_gopkgname/server.PDGitBranch=master -X $_gopkgname/server.PDGitHash=v$pkgver"
-
cd $GOPATH/src/$_gopkgname
+ sed -i '/shell git /d' Makefile
+ _LDFLAGS="-X $_gopkgname/server.PDReleaseVersion=$pkgver -X $_gopkgname/server.PDGitBranch=release -X $_gopkgname/server.PDGitHash=v$pkgver"
+
LDFLAGS=$_LDFLAGS make build
}