summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanwo2018-10-23 00:27:45 +0800
committerXuanwo2018-10-23 00:27:45 +0800
commit7f8a546ed264a861e33ea7dcc39cc1cfdaf8a49d (patch)
tree0cf3ee391018e241952ebde69120872e16075f7c
parent8745a77aa4f224e0054c6018463176d8ca3744fd (diff)
downloadaur-7f8a546ed264a861e33ea7dcc39cc1cfdaf8a49d.tar.gz
Add tmpfile for pd service
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
-rw-r--r--pd-tmpfiles.conf1
-rw-r--r--pd.service6
-rw-r--r--pd.toml2
6 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d84f8763338..d437b71875e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tikv-pd
pkgdesc = Manage and schedule the TiKV cluster.
pkgver = 2.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pingcap/pd
arch = x86_64
license = Apache
@@ -12,11 +12,13 @@ pkgbase = tikv-pd
source = pd-2.0.5.tar.gz::https://github.com/pingcap/pd/archive/v2.0.5.tar.gz
source = pd.service
source = pd-sysusers.conf
+ source = pd-tmpfiles.conf
source = pd.toml
sha256sums = 4f3d267aa0c34828aea8b4797a02041efa32e81cda2c72d51e0b1f5bafab858b
- sha256sums = 3b540c0cc468816b3be2d8d271f5649c836860c1e2eddfa7c043880bef226917
+ sha256sums = bc1c5dea8daa72ea602e6f5735cff55d2c46d8846168bac9b66a6f9d1993715e
sha256sums = 5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67
- sha256sums = 14d8031f7d5d071e99dd3291c966d246c89a852b9c54a889d83b7c01421a45fc
+ sha256sums = 15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495
+ sha256sums = 11bc441dfd0327c56218f214a9869da20ccdf7e5265c2f5ffca45089ba8094db
pkgname = tikv-pd
diff --git a/.gitignore b/.gitignore
index 335ec9573de5..2a4661c1b5a5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
-*.tar.gz
+*.tar
+*.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 712b4485cdcb..fee461dd06b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
pkgname=tikv-pd
pkgver=2.0.5
-pkgrel=1
+pkgrel=2
pkgdesc='Manage and schedule the TiKV cluster.'
makedepends=('go' 'make')
arch=('x86_64')
@@ -12,11 +12,13 @@ backup=(etc/pd/pd.toml)
source=(pd-${pkgver}.tar.gz::https://github.com/pingcap/pd/archive/v${pkgver}.tar.gz
pd.service
pd-sysusers.conf
+ pd-tmpfiles.conf
pd.toml)
sha256sums=('4f3d267aa0c34828aea8b4797a02041efa32e81cda2c72d51e0b1f5bafab858b'
- '3b540c0cc468816b3be2d8d271f5649c836860c1e2eddfa7c043880bef226917'
+ 'bc1c5dea8daa72ea602e6f5735cff55d2c46d8846168bac9b66a6f9d1993715e'
'5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67'
- '14d8031f7d5d071e99dd3291c966d246c89a852b9c54a889d83b7c01421a45fc')
+ '15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495'
+ '11bc441dfd0327c56218f214a9869da20ccdf7e5265c2f5ffca45089ba8094db')
_gopkgname='github.com/pingcap/pd'
@@ -51,6 +53,8 @@ package() {
install -Dm644 "$srcdir/pd.service" "$pkgdir/usr/lib/systemd/system/pd.service"
# Install sysusers
install -Dm644 "$srcdir/pd-sysusers.conf" "$pkgdir/usr/lib/sysusers.d/pd.conf"
+ # Install tmpfiles
+ install -Dm644 "$srcdir/pd-tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/pd.conf"
# Install default pd config
install -Dm644 pd.toml "$pkgdir/etc/pd/pd.toml"
diff --git a/pd-tmpfiles.conf b/pd-tmpfiles.conf
new file mode 100644
index 000000000000..c66e9ef6746c
--- /dev/null
+++ b/pd-tmpfiles.conf
@@ -0,0 +1 @@
+d /var/lib/pd 0755 pd pd -
diff --git a/pd.service b/pd.service
index d1993b14c0ca..6184102b3e70 100644
--- a/pd.service
+++ b/pd.service
@@ -4,12 +4,6 @@ Documentation=https://github.com/pingcap/pd
After=network.target
[Service]
-PermissionsStartOnly=true
-LimitNOFILE=1048576
-LimitNPROC=512
-CapabilityBoundingSet=CAP_NET_BIND_SERVICE
-AmbientCapabilities=CAP_NET_BIND_SERVICE
-NoNewPrivileges=true
User=pd
WorkingDirectory=~
ExecStart=/usr/bin/pd-server --config=/etc/pd/pd.toml
diff --git a/pd.toml b/pd.toml
index 156b85c8474a..808f40ede708 100644
--- a/pd.toml
+++ b/pd.toml
@@ -1,7 +1,7 @@
# PD Configuration.
name = "pd"
-data-dir = "default.pd"
+data-dir = "/var/lib/pd"
client-urls = "http://127.0.0.1:2379"
# if not set, use ${client-urls}