summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2020-09-02 18:53:25 +0800
committerAllen Zhong2020-09-02 18:53:25 +0800
commit87dc22377bc9f245c37779db20ab36e8b9cb3105 (patch)
tree1ddcd2e313010fbd213ac1919aa45a84a46219e8
parent70fdbe0372f1d3336a8892d74e19096ffd6b4ec8 (diff)
downloadaur-87dc22377bc9f245c37779db20ab36e8b9cb3105.tar.gz
upgpkg: tikv-pd 4.0.5-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 008c711a1adf..c95b83733f4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = tikv-pd
pkgdesc = Manage and schedule the TiKV cluster.
- pkgver = 4.0.4
+ pkgver = 4.0.5
pkgrel = 1
- url = https://github.com/pingcap/pd
+ url = https://github.com/tikv/pd
install = pd.install
arch = x86_64
license = Apache
@@ -12,12 +12,12 @@ pkgbase = tikv-pd
makedepends = unzip
provides = pd-server
backup = etc/pd/pd.toml
- source = pd-4.0.4.tar.gz::https://github.com/pingcap/pd/archive/v4.0.4.tar.gz
+ source = pd-4.0.5.tar.gz::https://github.com/tikv/pd/archive/v4.0.5.tar.gz
source = pd.service
source = pd-sysusers.conf
source = pd-tmpfiles.conf
source = pd.toml
- sha256sums = 85003b3c06f24a913385186dc1f3cf5328e972ee15bbed65eddb6e65b4dcfbbf
+ sha256sums = ee6f4e6f98ea69b2840a229701735ae5f1195fa624f1f4d23acd036d11bdb351
sha256sums = b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924
sha256sums = 5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67
sha256sums = 15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495
diff --git a/PKGBUILD b/PKGBUILD
index f707d3a28b9e..612e6fae52c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
# Maintainer: Allen Zhong <zhongbenli@pingcap.com>
pkgname=tikv-pd
-pkgver=4.0.4
+pkgver=4.0.5
pkgrel=1
pkgdesc='Manage and schedule the TiKV cluster.'
makedepends=('go' 'make' 'git' 'unzip')
arch=('x86_64')
-url='https://github.com/pingcap/pd'
+url='https://github.com/tikv/pd'
license=('Apache')
provides=('pd-server')
backup=(etc/pd/pd.toml)
install=pd.install
-source=(pd-${pkgver}.tar.gz::https://github.com/pingcap/pd/archive/v${pkgver}.tar.gz
+source=(pd-${pkgver}.tar.gz::https://github.com/tikv/pd/archive/v${pkgver}.tar.gz
pd.service
pd-sysusers.conf
pd-tmpfiles.conf
pd.toml)
-sha256sums=('85003b3c06f24a913385186dc1f3cf5328e972ee15bbed65eddb6e65b4dcfbbf'
+sha256sums=('ee6f4e6f98ea69b2840a229701735ae5f1195fa624f1f4d23acd036d11bdb351'
'b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924'
'5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67'
'15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495'
'dd3097d7f72da151d792894d2f3bb4188bfe9d445df8955d0f6f9b5c36980249')
-_gopkgname='github.com/pingcap/pd'
+_gopkgname='github.com/tikv/pd'
prepare() {
export GOPATH="$srcdir/build"
@@ -48,7 +48,7 @@ build() {
cd $GOPATH/src/$_gopkgname
- _LDFLAGS="-X $_gopkgname/v4/server.PDReleaseVersion=$pkgver -X $_gopkgname/v4/server.PDGitBranch=release -X $_gopkgname/v4/server.PDGitHash=v$pkgver"
+ _LDFLAGS="-X $_gopkgname/server/versioninfo.PDReleaseVersion=$pkgver -X $_gopkgname/server/versioninfo.PDGitBranch=release -X $_gopkgname/server/versioninfo.PDGitHash=v$pkgver"
LDFLAGS=$_LDFLAGS make build tools
}