summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2020-05-29 00:23:55 +0800
committerAllen Zhong2020-05-29 00:23:55 +0800
commitb4e2d49a444806fe396af41859dbb6a51b1811d3 (patch)
tree31f9cd8b306970a8738efd8dc6a9e17ab61965f8
parent9c86f7e23481754ca4d86a8f4161e70dd84509f6 (diff)
downloadaur-b4e2d49a444806fe396af41859dbb6a51b1811d3.tar.gz
upgpkg: tikv-pd 4.0.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb7b5c19d7e7..e8bb3345b7ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tikv-pd
pkgdesc = Manage and schedule the TiKV cluster.
- pkgver = 3.1.1
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/pingcap/pd
arch = x86_64
@@ -11,12 +11,12 @@ pkgbase = tikv-pd
makedepends = unzip
provides = pd-server
backup = etc/pd/pd.toml
- source = pd-3.1.1.tar.gz::https://github.com/pingcap/pd/archive/v3.1.1.tar.gz
+ source = pd-4.0.0.tar.gz::https://github.com/pingcap/pd/archive/v4.0.0.tar.gz
source = pd.service
source = pd-sysusers.conf
source = pd-tmpfiles.conf
source = pd.toml
- sha256sums = 2d812ba70cd6f35154e5dbffa2b77ffdd647bcd71bd12b677bd373f8b5a50cb9
+ sha256sums = 8ccd9456b2b6df47f11555b06f84fe73c7672d921a0f949aa94bf24c3925fe62
sha256sums = b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924
sha256sums = 5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67
sha256sums = 15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495
diff --git a/PKGBUILD b/PKGBUILD
index 4ca5eb3c77cf..ce72c9bc5510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
# Maintainer: Allen Zhong <zhongbenli@pingcap.com>
pkgname=tikv-pd
-pkgver=3.1.1
+pkgver=4.0.0
pkgrel=1
pkgdesc='Manage and schedule the TiKV cluster.'
makedepends=('go' 'make' 'git' 'unzip')
@@ -15,7 +15,7 @@ source=(pd-${pkgver}.tar.gz::https://github.com/pingcap/pd/archive/v${pkgver}.ta
pd-sysusers.conf
pd-tmpfiles.conf
pd.toml)
-sha256sums=('2d812ba70cd6f35154e5dbffa2b77ffdd647bcd71bd12b677bd373f8b5a50cb9'
+sha256sums=('8ccd9456b2b6df47f11555b06f84fe73c7672d921a0f949aa94bf24c3925fe62'
'b03d12f2f8d6eb2e9d654d6258ca39000225cdf1418840f7e35081631bc4d924'
'5edd250ba9e70a4f8d27581ed658f0fbfeca58ca62429dec12bb5fffc0919b67'
'15633aaa2d7726375112a1b5af88105878f09c176a542cde6d0e5f0c4eee4495'
@@ -41,7 +41,7 @@ build() {
cd $GOPATH/src/$_gopkgname
sed -i '/shell git /d' Makefile
- _LDFLAGS="-X $_gopkgname/v3/server.PDReleaseVersion=$pkgver -X $_gopkgname/v3/server.PDGitBranch=release -X $_gopkgname/v3/server.PDGitHash=v$pkgver"
+ _LDFLAGS="-X $_gopkgname/v4/server.PDReleaseVersion=$pkgver -X $_gopkgname/v4/server.PDGitBranch=release -X $_gopkgname/v4/server.PDGitHash=v$pkgver"
LDFLAGS=$_LDFLAGS make build tools
}