summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-10-25 20:25:52 +0200
committerhaawda2018-10-25 20:25:52 +0200
commitce95c783bf1634bd1e9e8884997075fb1c4ee61c (patch)
tree5be9df7044ef4988d0b3c96187ba3809efe338d5
parent947c67b337805c2dbf4750b659e65555401d4e33 (diff)
downloadaur-ce95c783bf1634bd1e9e8884997075fb1c4ee61c.tar.gz
complete rewrite
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 800c0db67ca3..0c1bda2d2093 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
pkgbase = tikzit
pkgdesc = Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library
- pkgver = 1.0
- pkgrel = 2
- url = http://sourceforge.net/projects/tikzit/
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://tikzit.github.io/
arch = i686
arch = x86_64
license = GPL2
- makedepends = gcc-objc>=4.6.0
- depends = gnustep-base>=1.18.0
- depends = gtk2>=2.18.0
- depends = gnustep-make
- depends = poppler-glib>=0.10
- depends = hicolor-icon-theme
- depends = desktop-file-utils
+ makedepends = gcc-objc
+ depends = qt5-base
optdepends = texlive-core: previews
- source = http://downloads.sourceforge.net/sourceforge/tikzit/tikzit-1.0.tar.bz2
- md5sums = 5d7fc5a74500b8eb2545d0c4fece62a5
+ source = tikzit-2.0.tar.gz::https://github.com/tikzit/tikzit/archive/v2.0.tar.gz
+ sha256sums = d1a84531b8ac2298c140217267423cd9ce4d84ee443b5deb4aa47e4beab4f295
pkgname = tikzit
diff --git a/PKGBUILD b/PKGBUILD
index 10a7ca681479..2a23627241e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,28 @@
# Based on original tikzit-aur-package made by pippin
pkgname=tikzit
-pkgver=1.0
-pkgrel=2
+pkgver=2.0
+pkgrel=1
pkgdesc="Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library"
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/tikzit/"
+url="https://tikzit.github.io/"
license=('GPL2')
-depends=('gnustep-base>=1.18.0' 'gtk2>=2.18.0' 'gnustep-make'
- 'poppler-glib>=0.10' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('gcc-objc>=4.6.0')
+depends=('qt5-base')
+makedepends=('gcc-objc')
optdepends=('texlive-core: previews')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2)
-md5sums=('5d7fc5a74500b8eb2545d0c4fece62a5')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tikzit/tikzit/archive/v$pkgver.tar.gz")
+sha256sums=('d1a84531b8ac2298c140217267423cd9ce4d84ee443b5deb4aa47e4beab4f295')
build() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ qmake PREFIX=/usr \
+ QMAKE_CFLAGS="${CFLAGS}" \
+ QMAKE_CXXFLAGS="${CXXFLAGS}" tikzit.pro
+ make -j1
make
}
package() {
- cd $pkgname-$pkgver
- make "DESTDIR=$pkgdir" install
+ cd $pkgname-$pkgver1
+ install -Dm755 tikzit "$pkgdir"/usr/bin/tikzit
}