summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Merry2015-07-22 22:36:06 +0100
committerAlex Merry2015-07-22 22:36:31 +0100
commite411de993710ba810e3fdcb87b1daf6670acb3f4 (patch)
tree10548352adbe30dee0b8ab27ce6b797a39bbd07a
parentf4dd828619b9cbdbabf0c3faeefb3ef20f71ef61 (diff)
downloadaur-e411de993710ba810e3fdcb87b1daf6670acb3f4.tar.gz
v1.1 (from new location on GitHub)
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
-rw-r--r--tikzit.install1
4 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 755e19bda800..59e2500f97b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = tikzit
pkgdesc = Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library
- pkgver = 1.0
+ pkgver = 1.1
pkgrel = 1
- url = http://sourceforge.net/projects/tikzit/
+ url = http://tikzit.github.io
install = tikzit.install
arch = i686
arch = x86_64
license = GPL2
makedepends = gcc-objc>=4.6.0
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = flex
+ makedepends = bison
depends = gnustep-base>=1.18.0
depends = gtk2>=2.18.0
depends = poppler-glib>=0.10
- depends = hicolor-icon-theme
depends = desktop-file-utils
optdepends = texlive-core: previews
- source = http://downloads.sourceforge.net/sourceforge/tikzit/tikzit-1.0.tar.bz2
- md5sums = 5d7fc5a74500b8eb2545d0c4fece62a5
+ source = https://github.com/tikzit/tikzit/archive/v1.1.tar.gz
+ md5sums = ca71f1f862136f10965323400be4f34f
pkgname = tikzit
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..418d50536e90
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.pkg.tar.*
+/v*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 0b0edb9ce339..7c6d33fdb11f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
+# Maintainer: Alex Merry <dev@randomguy3.me.uk>
+
pkgname=tikzit
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library"
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/tikzit/"
+url="http://tikzit.github.io"
license=('GPL2')
depends=('gnustep-base>=1.18.0' 'gtk2>=2.18.0'
- 'poppler-glib>=0.10' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('gcc-objc>=4.6.0')
+ 'poppler-glib>=0.10' 'desktop-file-utils')
+makedepends=('gcc-objc>=4.6.0' 'automake' 'autoconf' 'flex' 'bison')
optdepends=('texlive-core: previews')
install="tikzit.install"
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2)
-md5sums=('5d7fc5a74500b8eb2545d0c4fece62a5')
+source=(https://github.com/$pkgname/$pkgname/archive/v${pkgver}.tar.gz)
+md5sums=('ca71f1f862136f10965323400be4f34f')
build() {
source /etc/profile.d/GNUstep.sh
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver/tikzit"
+ ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make || return 1
}
package() {
source /etc/profile.d/GNUstep.sh
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver/tikzit"
make "DESTDIR=$pkgdir" install || return 1
}
diff --git a/tikzit.install b/tikzit.install
index c317fbaca442..2393d439188a 100644
--- a/tikzit.install
+++ b/tikzit.install
@@ -1,6 +1,7 @@
post_install() {
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-mime-database usr/share/mime
}
post_upgrade() {