summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Merry2015-06-14 19:25:06 +0100
committerAlex Merry2015-06-14 19:25:06 +0100
commitf4dd828619b9cbdbabf0c3faeefb3ef20f71ef61 (patch)
tree0502912e1bc842dfac2e69ead6162ebe9c429179
downloadaur-f4dd828619b9cbdbabf0c3faeefb3ef20f71ef61.tar.gz
Import from AUR 3
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--tikzit.install12
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..755e19bda800
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tikzit
+ pkgdesc = Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/tikzit/
+ install = tikzit.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc-objc>=4.6.0
+ depends = gnustep-base>=1.18.0
+ depends = gtk2>=2.18.0
+ depends = poppler-glib>=0.10
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ optdepends = texlive-core: previews
+ source = http://downloads.sourceforge.net/sourceforge/tikzit/tikzit-1.0.tar.bz2
+ md5sums = 5d7fc5a74500b8eb2545d0c4fece62a5
+
+pkgname = tikzit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b0edb9ce339
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=tikzit
+pkgver=1.0
+pkgrel=1
+pkgdesc="Allows the creation and modification of TeX diagrams written using the pgf/TikZ macro library"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/tikzit/"
+license=('GPL2')
+depends=('gnustep-base>=1.18.0' 'gtk2>=2.18.0'
+ 'poppler-glib>=0.10' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('gcc-objc>=4.6.0')
+optdepends=('texlive-core: previews')
+install="tikzit.install"
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2)
+md5sums=('5d7fc5a74500b8eb2545d0c4fece62a5')
+
+build() {
+ source /etc/profile.d/GNUstep.sh
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make || return 1
+}
+
+package() {
+ source /etc/profile.d/GNUstep.sh
+ cd "$srcdir/$pkgname-$pkgver"
+ make "DESTDIR=$pkgdir" install || return 1
+}
+
+# vim: set ts=2 sw=2 et:
diff --git a/tikzit.install b/tikzit.install
new file mode 100644
index 000000000000..c317fbaca442
--- /dev/null
+++ b/tikzit.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}