summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-05-28 17:39:01 +0200
committerhaawda2018-05-28 17:39:01 +0200
commit49bd9b790d0d4523bf9d49658fa2d02bdac1240e (patch)
tree756fc61abcf42bcc98fa03759670260273d9f34e
parent523c4460ffd567d3e288d5488de5b78a0ca366bc (diff)
downloadaur-49bd9b790d0d4523bf9d49658fa2d02bdac1240e.tar.gz
major rewrite: c++ instead of objective-c, Qt instead of GNUstep
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7118bc394b19..292b1ef7dee7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,14 @@
pkgbase = tikzit-git
- pkgdesc = Creation and modification of TeX diagrams written using the pgf/TikZ macro library
- pkgver = r297
- pkgrel = 2
+ pkgdesc = Creation and modification of TeX diagrams written using the pgf/TikZ macro library - rewrite in QT and C++
+ pkgver = r376
+ pkgrel = 1
url = https://github.com/tikzit/tikzit.git
arch = i686
arch = x86_64
license = GPL
makedepends = git
- makedepends = gcc-objc
- depends = gtk2>=2.18.0
- depends = poppler-glib
- depends = hicolor-icon-theme
- depends = gnustep-base
- depends = desktop-file-utils
+ depends = qt5-base
provides = tikzit
- conflicts = tikzit
options = !makeflags
source = git+https://github.com/tikzit/tikzit.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index cbf78608ff81..b1575e6d7c7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,15 @@
# Based on original tikzit-aur-package made by pippin
pkgname=tikzit-git
-pkgver=r297
-pkgrel=2
-pkgdesc="Creation and modification of TeX diagrams written using the pgf/TikZ macro library"
+pkgver=r376
+pkgrel=1
+pkgdesc="Creation and modification of TeX diagrams written using the pgf/TikZ macro library - rewrite in QT and C++"
arch=('i686' 'x86_64')
url="https://github.com/tikzit/tikzit.git"
license=('GPL')
-depends=('gtk2>=2.18.0' 'poppler-glib' 'hicolor-icon-theme' 'gnustep-base' 'desktop-file-utils')
-makedepends=('git' 'gcc-objc')
+depends=('qt5-base')
+makedepends=('git')
provides=('tikzit')
-conflicts=('tikzit')
source=('git+https://github.com/tikzit/tikzit.git')
md5sums=('SKIP')
options=('!makeflags')
@@ -24,13 +23,14 @@ pkgver() {
}
build() {
- cd "$srcdir"/${pkgname%-git}/${pkgname%-git}
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
- make
+ cd ${pkgname%-git}
+ qmake PREFIX=/usr \
+ QMAKE_CFLAGS="${CFLAGS}" \
+ QMAKE_CXXFLAGS="${CXXFLAGS}" tikzit.pro
+ make -j1
}
package() {
- cd "$srcdir"/${pkgname%-git}/${pkgname%-git}
- make DESTDIR="$pkgdir" install
+ cd ${pkgname%-git}
+ install -Dm755 tikzit "$pkgdir"/usr/bin/tikzit-qt
}