summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-10-25 20:26:28 +0200
committerhaawda2018-10-25 20:26:28 +0200
commit8ce395442722cf30f0e22032c7a43e93c7494c9c (patch)
tree505b69f2c19148e40d07fefa685ab793f3d0dd7f
parent49bd9b790d0d4523bf9d49658fa2d02bdac1240e (diff)
downloadaur-8ce395442722cf30f0e22032c7a43e93c7494c9c.tar.gz
new pkgver function
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 292b1ef7dee7..c1da599db3b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = tikzit-git
pkgdesc = Creation and modification of TeX diagrams written using the pgf/TikZ macro library - rewrite in QT and C++
- pkgver = r376
+ pkgver = 2.0.5.g19a3a0f
pkgrel = 1
- url = https://github.com/tikzit/tikzit.git
+ url = https://tikzit.github.io/
arch = i686
arch = x86_64
license = GPL
makedepends = git
depends = qt5-base
provides = tikzit
+ conflicts = tikzit
options = !makeflags
source = git+https://github.com/tikzit/tikzit.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b1575e6d7c7f..26718bf691a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,23 @@
# Based on original tikzit-aur-package made by pippin
pkgname=tikzit-git
-pkgver=r376
+pkgver=2.0.5.g19a3a0f
pkgrel=1
pkgdesc="Creation and modification of TeX diagrams written using the pgf/TikZ macro library - rewrite in QT and C++"
arch=('i686' 'x86_64')
-url="https://github.com/tikzit/tikzit.git"
+url="https://tikzit.github.io/"
license=('GPL')
depends=('qt5-base')
makedepends=('git')
provides=('tikzit')
+conflicts=('tikzit')
source=('git+https://github.com/tikzit/tikzit.git')
md5sums=('SKIP')
options=('!makeflags')
pkgver() {
cd ${pkgname%-git}
- printf "r%s" "$(git rev-list --count HEAD)"
+ printf "%s" "$(git describe --tags | cut -c2- |tr - .)"
}
build() {
@@ -32,5 +33,5 @@ build() {
package() {
cd ${pkgname%-git}
- install -Dm755 tikzit "$pkgdir"/usr/bin/tikzit-qt
+ install -Dm755 tikzit "$pkgdir"/usr/bin/tikzit
}