summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjerry732042018-08-26 05:20:30 +0800
committerjerry732042018-08-26 05:20:30 +0800
commitcbe76cca920f72550978834f11af6815081be1d4 (patch)
tree2cc43c4a2be74daad36109a0bc432d0bf8c8b964
downloadaur-cbe76cca920f72550978834f11af6815081be1d4.tar.gz
Upload version 2.11-1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD79
-rw-r--r--apache.example.conf29
3 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52e9360ed924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = tilecache
+ pkgdesc = TileCache is an implementation of a WMS-C compliant server made available under the BSD license by MetaCarta.
+ pkgver = 2.11
+ pkgrel = 1
+ url = http://tilecache.org/
+ arch = x86_64
+ license = BSD
+ depends = python2
+ optdepends = memcached
+ optdepends = mapserver
+ optdepends = python2-pillow
+ optdepends = python2-boto
+ optdepends = python2-flup
+ optdepends = python2-mapnik
+ optdepends = python2-memcached
+ optdepends = python2-wsgiref
+ optdepends = python2-paste
+ source = http://tilecache.org/tilecache-2.11.tar.gz
+ source = apache.example.conf
+ sha256sums = b46dc2731a19b40e3207cf3c9b43ea59b899a622a586aaa3c397c3b5aa00f887
+ sha256sums = 06583b0fdbee9a057d8e8aeb3591a4cd1d5dbe230c71f4f0f0588042dc0dce57
+
+pkgname = tilecache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89a32bb3cafb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: jerry73204 <jerry73204 at gmail dot com>
+pkgname=tilecache
+pkgver=2.11
+pkgrel=1
+pkgdesc='TileCache is an implementation of a WMS-C compliant server made available under the BSD license by MetaCarta.'
+arch=('x86_64')
+url='http://tilecache.org/'
+license=('BSD')
+depends=('python2')
+optdepends=(
+ 'memcached'
+ 'mapserver'
+ 'python2-pillow'
+ 'python2-boto'
+ 'python2-flup'
+ 'python2-mapnik'
+ 'python2-memcached'
+ 'python2-wsgiref'
+ 'python2-paste'
+)
+source=("http://tilecache.org/${pkgname}-${pkgver}.tar.gz"
+ 'apache.example.conf')
+sha256sums=('b46dc2731a19b40e3207cf3c9b43ea59b899a622a586aaa3c397c3b5aa00f887'
+ '06583b0fdbee9a057d8e8aeb3591a4cd1d5dbe230c71f4f0f0588042dc0dce57')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i 's_#!/usr/bin/python_#!/usr/bin/env python2_g' \
+ ez_setup.py \
+ setup.py \
+ tilecache_clean.py \
+ tilecache_http_server.py \
+ tilecache_install_config.py \
+ tilecache_seed.py \
+ tilecache.cgi \
+ tilecache.fcgi
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # compile Python scripts
+ python2 setup.py build
+
+ # build docs
+ cd docs
+ make html
+}
+
+package() {
+ # install Python scripts
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ install -dm0755 "${pkgdir}/etc"
+ install -m0644 tilecache.cfg "${pkgdir}/etc/tilecache.cfg"
+ rm -v "${pkgdir}/usr/dev.ini" # remove unused dev.ini
+
+ # install docs
+ cd "${srcdir}/${pkgname}-${pkgver}/docs/_build"
+ local DOCS_DIR="${pkgdir}/usr/share/doc/tilecache"
+ install -dm0755 "$DOCS_DIR"
+ cp -rv html "$DOCS_DIR/html"
+
+ # install example apache config
+ cd "${srcdir}"
+ local CONFIG_DIR="${pkgdir}/etc/webapps/tilecache"
+ install -dm0755 "$CONFIG_DIR"
+ install -m0644 apache.example.conf "$CONFIG_DIR/apache.example.conf"
+
+ # build CGI directory
+ local CGI_DIR="${pkgdir}/usr/share/tilecache/sbin"
+ install -dm0755 "$CGI_DIR"
+ mv -v "${pkgdir}/usr/bin/tilecache.cgi" "${CGI_DIR}/tilecache.cgi"
+ mv -v "${pkgdir}/usr/bin/tilecache.fcgi" "${CGI_DIR}/tilecache.fcgi"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..558889fd2ba4
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,29 @@
+# SAMPLE CONFIG FOR APACHE WEB SERVER
+#
+# This file contains entries that need to be incorporated into
+# your Apache web server configuration file.
+#
+# Copy this file to /etc/httpd/conf/extra/tilecache.conf.
+# Enable cgid_module in /etc/httpd/conf/httpd.conf, and include tilecache.conf.
+
+Alias /tilecache/cgi-bin "/usr/share/tilecache/sbin"
+
+<Directory "/usr/share/tilecache/sbin">
+ #SSLRequireSSL
+ Options ExecCGI
+ AddHandler cgi-script .cgi
+ AllowOverride None
+ <IfVersion >= 2.3>
+ <RequireAll>
+ Require all granted
+ #Require host 127.0.0.1
+ </RequireAll>
+ </IfVersion>
+ <IfVersion < 2.3>
+ Order allow,deny
+ Allow from all
+ #Order deny,allow
+ #Deny from all
+ #Allow from 127.0.0.1
+ </IfVersion>
+</Directory>