summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavi da Silva Böger2017-03-23 11:37:25 -0300
committerDavi da Silva Böger2017-03-23 11:37:25 -0300
commit5d537a2db630c76a57af9e7429485f2d5c8e5fcb (patch)
treeaf63b4e11ceb46844034778b77e6d7641e13a1e3
parentf8b2935dfa6c302a96f0990c5deda1ce0f76fc40 (diff)
downloadaur-5d537a2db630c76a57af9e7429485f2d5c8e5fcb.tar.gz
Migrate to tilix, update optdepends
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD18
2 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ececfe499000..f7b753e07418 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Mar 2 19:01:54 UTC 2017
-pkgbase = terminix
+# Thu Mar 23 14:37:04 UTC 2017
+pkgbase = tilix-bin
pkgdesc = A tiling terminal emulator based on GTK+ 3 (binary distribution)
- pkgver = 1.5.2
- pkgrel = 2
- url = http://github.com/gnunn1/terminix
+ pkgver = 1.5.4
+ pkgrel = 1
+ url = http://github.com/gnunn1/tilix
arch = x86_64
license = MPL
depends = liblphobos
@@ -14,9 +14,12 @@ pkgbase = terminix
depends = vte3
depends = hicolor-icon-theme
depends = libx11
- optdepends = python2-nautilus: for "Open Terminix Here" support in nautilus
- source_x86_64 = terminix-1.5.2.zip::https://github.com/gnunn1/terminix/releases/download/1.5.2/terminix.zip
- md5sums_x86_64 = edf55dd0d85e46d5ad79126c879b4529
+ optdepends = python2-nautilus: for "Open Tilix Here" support in nautilus
+ optdepends = vte3-notification: for desktop notifications support
+ optdepends = vte3-tilix: for notifications, triggers and badges support
+ optdepends = libsecret: for password manager
+ source_x86_64 = tilix-1.5.4.zip::https://github.com/gnunn1/tilix/releases/download/1.5.4/tilix.zip
+ md5sums_x86_64 = 20d2969d686408051330e9645e70987b
-pkgname = terminix
+pkgname = tilix-bin
diff --git a/PKGBUILD b/PKGBUILD
index 35a2e4c28f9d..00dca10ef1ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Contributor: Gerald Nunn <gerald dot b dot nunn at gmail dot com>
# Maintainer: Davi da Silva Böger <dsboger at gmail dot com>
-pkgname=terminix
-pkgver=1.5.2
-pkgrel=2
+pkgname=tilix-bin
+_pkgname=tilix
+pkgver=1.5.4
+pkgrel=1
pkgdesc="A tiling terminal emulator based on GTK+ 3 (binary distribution)"
arch=('x86_64')
-url="http://github.com/gnunn1/terminix"
+url="http://github.com/gnunn1/tilix"
license=('MPL')
depends=('liblphobos' 'gtk3' 'dconf' 'gsettings-desktop-schemas' 'vte3' 'hicolor-icon-theme' 'libx11')
-optdepends=('python2-nautilus: for "Open Terminix Here" support in nautilus')
-source_x86_64=(${pkgname}-${pkgver}.zip::https://github.com/gnunn1/terminix/releases/download/${pkgver}/terminix.zip)
-md5sums_x86_64=('edf55dd0d85e46d5ad79126c879b4529')
+optdepends=('python2-nautilus: for "Open Tilix Here" support in nautilus'
+ 'vte3-notification: for desktop notifications support'
+ 'vte3-tilix: for notifications, triggers and badges support'
+ 'libsecret: for password manager')
+source_x86_64=(${_pkgname}-${pkgver}.zip::https://github.com/gnunn1/tilix/releases/download/${pkgver}/${_pkgname}.zip)
+md5sums_x86_64=('20d2969d686408051330e9645e70987b')
package() {
cp -ar $srcdir/usr $pkgdir/usr