summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeopold Bloom2015-08-26 17:13:45 -0400
committerLeopold Bloom2015-08-26 17:13:45 -0400
commitec187803f7d1becfa13bf40c1d40176704c3e2c8 (patch)
tree6a760d129523f9636a47f473f1525751e035bbfb
downloadaur-ec187803f7d1becfa13bf40c1d40176704c3e2c8.tar.gz
initial
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD47
-rw-r--r--tilp.desktop14
-rw-r--r--tilp.install19
-rw-r--r--tilp.xml250
5 files changed, 355 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cb502c1991e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = tilp
+ pkgdesc = TI graphing calculator link/transfer program
+ pkgver = 1.17
+ pkgrel = 3
+ url = http://lpg.ticalc.org/prj_tilp/
+ install = tilp.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ depends = desktop-file-utils
+ depends = libticalcs
+ optdepends = gfm: to manage and manipulate TI Group Files (backups)
+ source = http://sourceforge.net/projects/tilp/files/tilp2-linux/tilp2-1.17/tilp2-1.17.tar.bz2
+ source = tilp.desktop
+ source = tilp.xml
+ sha256sums = 0bc744463450843c0f1e9deebf45af84a282304aff37865077ca7146d54ff6e7
+ sha256sums = 004443e1c21ee7931bfe74052d7828312e9303681aac50a97c7d6af5cabd3214
+ sha256sums = 613ecd5e8c8a2ac98abde43909c851c365acffd5d2fb553920840347d71836bd
+ sha512sums = 78f0242710a8c86a6db7d764e6e524b373aef0384f649b0e538ac1f4a57044fc9adf3aa32da9dc69509b6d835d020026bbdf574cdbb7f1f5a53ab316b987c572
+ sha512sums = 25a0bf3c3fa4dae1cf553304ad180f5f5dc604a2950153b71df43b05f1cd4a2654f32312f46fa9b20b28c03450993cb9afdcce5afa2f3eabc13c11906e21f66a
+ sha512sums = cd2739fff44f7fb943f55cbd2775a1e265e04eabf8ee7058e333bf4f023d857899c9fa5e27a0d229dcebdc4c473b04a4e70b34e18bc52badc34820cf1383b1c4
+
+pkgname = tilp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c0d3b34cb37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Taylor Lookabaugh <jesus.christ.i.love@gmail.com>
+# Contributor: Jon Sturm <Jasturm002@aol.com>
+# Contributor: Scott Garrett <Wintervenom@archlinux.us>
+
+pkgname=tilp
+pkgver=1.17
+pkgrel=3
+pkgdesc="TI graphing calculator link/transfer program"
+arch=(i686 x86_64)
+url=http://lpg.ticalc.org/prj_tilp/
+license=(GPL2)
+depends=(desktop-file-utils libticalcs)
+makedepends=(intltool)
+optdepends=('gfm: to manage and manipulate TI Group Files (backups)')
+install=$pkgname.install
+source=(http://sourceforge.net/projects/tilp/files/tilp2-linux/tilp2-$pkgver/${pkgname}2-$pkgver.tar.bz2
+ $pkgname.desktop
+ $pkgname.xml)
+sha256sums=('0bc744463450843c0f1e9deebf45af84a282304aff37865077ca7146d54ff6e7'
+ '004443e1c21ee7931bfe74052d7828312e9303681aac50a97c7d6af5cabd3214'
+ '613ecd5e8c8a2ac98abde43909c851c365acffd5d2fb553920840347d71836bd')
+sha512sums=('78f0242710a8c86a6db7d764e6e524b373aef0384f649b0e538ac1f4a57044fc9adf3aa32da9dc69509b6d835d020026bbdf574cdbb7f1f5a53ab316b987c572'
+ '25a0bf3c3fa4dae1cf553304ad180f5f5dc604a2950153b71df43b05f1cd4a2654f32312f46fa9b20b28c03450993cb9afdcce5afa2f3eabc13c11906e21f66a'
+ 'cd2739fff44f7fb943f55cbd2775a1e265e04eabf8ee7058e333bf4f023d857899c9fa5e27a0d229dcebdc4c473b04a4e70b34e18bc52badc34820cf1383b1c4')
+
+prepare() {
+ cd ${pkgname}2-$pkgver/
+ sed -i 's:.*serial.*::g' acinclude.m4
+ echo '# serial 1' > acinclude.m4.new
+ cat acinclude.m4 >> acinclude.m4.new
+ mv acinclude.m4{.new,}
+}
+
+build() {
+ cd ${pkgname}2-$pkgver/
+ autoreconf -fi
+ #KDE users can remove the --without-kde option to enable kde file dialogs
+ ./configure --prefix=/usr --without-kde
+ make
+}
+
+package() {
+ make -C ${pkgname}2-$pkgver DESTDIR="$pkgdir" install
+ desktop-file-install $pkgname.desktop --dir "$pkgdir"/usr/share/applications/
+ install -Dm644 $pkgname.xml "$pkgdir"/usr/share/mime/packages/$pkgname.xml
+}
diff --git a/tilp.desktop b/tilp.desktop
new file mode 100644
index 000000000000..da0b06b09492
--- /dev/null
+++ b/tilp.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=TiLP
+Name[fr_FR]=TiLP
+Comment=Linking program for TI calculators
+Comment[fr_FR]=Programme de connexion pour calculatrices TI
+GenericName=TI Linking Program
+GenericName[fr_FR]=Connexion calculatrices TI
+Version=1.0
+Type=Application
+Exec=tilp
+Icon=/usr/share/tilp2/pixmaps/icon.xpm
+Terminal=false
+Categories=Utility;X-KDE-Utilities-Peripherals;
+MimeType=application/x-tilp;
diff --git a/tilp.install b/tilp.install
new file mode 100644
index 000000000000..765dfb9bd244
--- /dev/null
+++ b/tilp.install
@@ -0,0 +1,19 @@
+post_install() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ echo "update desktop mime database..."
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+post_remove() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ echo "update desktop mime database..."
+ update-desktop-database -q
+}
diff --git a/tilp.xml b/tilp.xml
new file mode 100644
index 000000000000..fad2af1a787e
--- /dev/null
+++ b/tilp.xml
@@ -0,0 +1,250 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-tilp">
+ <comment xml:lang="en">TI File</comment>
+ <comment xml:lang="fr">Fichier TI</comment>
+ <glob pattern="*.73?" />
+ <glob pattern="*.8[23569x]?" />
+ <glob pattern="*.9[2x]?" />
+ <glob pattern="*.v2?" />
+ <magic priority="25">
+ <match type="string" offset="0" value="**TI"/>
+ </magic>
+ </mime-type>
+ <mime-type type="application/x-tilp-window_setup">
+ <comment xml:lang="en">Ti File (Window Setup)</comment>
+ <comment xml:lang="fr">Fichier TI (Window Setup)</comment>
+ <glob pattern="*.8[2356x]w" />
+ <glob pattern="*.73w" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-y_var">
+ <comment xml:lang="en">Ti File (Y-Var)</comment>
+ <comment xml:lang="fr">Fichier TI (Y-Var)</comment>
+ <glob pattern="*.8[2356]y" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-zip">
+ <comment xml:lang="en">Ti File (Zip'ed)</comment>
+ <comment xml:lang="fr">Fichier TI (Compressé)</comment>
+ <glob pattern="*.89y" />
+ <glob pattern="*.9[2x]y" />
+ <glob pattern="*.v2y" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-zoom">
+ <comment xml:lang="en">Ti File (Zoom)</comment>
+ <comment xml:lang="fr">Fichier TI (Zoom)</comment>
+ <glob pattern="*.73z" />
+ <glob pattern="*.8[2356x]z" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-app_var">
+ <comment xml:lang="en">Ti File (Application Variable)</comment>
+ <comment xml:lang="fr">Fichier TI (Variable Application)</comment>
+ <glob pattern="*.8xv" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-application">
+ <comment xml:lang="en">Ti File (Application)</comment>
+ <comment xml:lang="fr">Fichier TI (Application)</comment>
+ <glob pattern="*.73k" />
+ <glob pattern="*.8[9x]k" />
+ <glob pattern="*.9xk" />
+ <glob pattern="*.v2k" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-program">
+ <comment xml:lang="en">Ti File (Program)</comment>
+ <comment xml:lang="fr">Fichier TI (Programme)</comment>
+ <glob pattern="*.73p" />
+ <glob pattern="*.8[23569x]p" />
+ <glob pattern="*.9[2x]p" />
+ <glob pattern="*.v2p" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-backup">
+ <comment xml:lang="en">Ti File (Backup)</comment>
+ <comment xml:lang="fr">Fichier TI (Sauvegarde)</comment>
+ <glob pattern="*.73b" />
+ <glob pattern="*.8[2356x]b" />
+ <glob pattern="*.92b" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-certificate">
+ <comment xml:lang="en">Ti File (Certificate)</comment>
+ <comment xml:lang="fr">Fichier TI (Certificat)</comment>
+ <glob pattern="*.73q" />
+ <glob pattern="*.8[9x]q" />
+ <glob pattern="*.9xq" />
+ <glob pattern="*.v2q" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-complex">
+ <comment xml:lang="en">Ti File (Certificate)</comment>
+ <comment xml:lang="fr">Fichier TI (Certificat)</comment>
+ <glob pattern="*.73c" />
+ <glob pattern="*.8[2356x]c" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-constant">
+ <comment xml:lang="en">Ti File (Constant)</comment>
+ <comment xml:lang="fr">Fichier TI (Constante)</comment>
+ <glob pattern="*.8[56]k" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-data">
+ <comment xml:lang="en">Ti File (Data)</comment>
+ <comment xml:lang="fr">Fichier TI (Données)</comment>
+ <glob pattern="*.89c" />
+ <glob pattern="*.9[2x]c" />
+ <glob pattern="*.v2c" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-equation">
+ <comment xml:lang="en">Ti File (Equation)</comment>
+ <comment xml:lang="fr">Fichier TI (Equation)</comment>
+ <glob pattern="*.73e" />
+ <glob pattern="*.8[2356x]e" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-expression">
+ <comment xml:lang="en">Ti File (Expression)</comment>
+ <comment xml:lang="fr">Fichier TI (Expression)</comment>
+ <glob pattern="*.89e" />
+ <glob pattern="*.9[2x]ce" />
+ <glob pattern="*.v2e" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-expression">
+ <comment xml:lang="en">Ti File (Expression)</comment>
+ <comment xml:lang="fr">Fichier TI (Expression)</comment>
+ <glob pattern="*.89e" />
+ <glob pattern="*.9[2x]e" />
+ <glob pattern="*.v2e" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-figure">
+ <comment xml:lang="en">Ti File (Figure)</comment>
+ <comment xml:lang="fr">Fichier TI (Figure)</comment>
+ <glob pattern="*.89a" />
+ <glob pattern="*.9[2x]a" />
+ <glob pattern="*.v2a" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-function">
+ <comment xml:lang="en">Ti File (Function)</comment>
+ <comment xml:lang="fr">Fichier TI (Function)</comment>
+ <glob pattern="*.89f" />
+ <glob pattern="*.9[2x]f" />
+ <glob pattern="*.v2f" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-gdb">
+ <comment xml:lang="en">Ti File (GDB)</comment>
+ <comment xml:lang="fr">Fichier TI (GDB)</comment>
+ <glob pattern="*.73d" />
+ <glob pattern="*.8[23569x]d" />
+ <glob pattern="*.9[2x]d" />
+ <glob pattern="*.v2d" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-group">
+ <comment xml:lang="en">Ti File (Group)</comment>
+ <comment xml:lang="fr">Fichier TI (Groupe)</comment>
+ <glob pattern="*.73g" />
+ <glob pattern="*.8[23569x]g" />
+ <glob pattern="*.9[2x]g" />
+ <glob pattern="*.v2g" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-list">
+ <comment xml:lang="en">Ti File (List)</comment>
+ <comment xml:lang="fr">Fichier TI (List)</comment>
+ <glob pattern="*.73l" />
+ <glob pattern="*.8[23569x]l" />
+ <glob pattern="*.9[2x]l" />
+ <glob pattern="*.v2l" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-macro">
+ <comment xml:lang="en">Ti File (Macro)</comment>
+ <comment xml:lang="fr">Fichier TI (Macro)</comment>
+ <glob pattern="*.89x" />
+ <glob pattern="*.9[2x]x" />
+ <glob pattern="*.v2x" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-os_upgrade">
+ <comment xml:lang="en">Ti File (OS Update)</comment>
+ <comment xml:lang="fr">Fichier TI (MAJ du SE)</comment>
+ <glob pattern="*.73u" />
+ <glob pattern="*.8[9x]u" />
+ <glob pattern="*.9xu" />
+ <glob pattern="*.v2u" />
+ <glob pattern="*.tib" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-picture">
+ <comment xml:lang="en">Ti File (Picture)</comment>
+ <comment xml:lang="fr">Fichier TI (Image)</comment>
+ <glob pattern="*.73i" />
+ <glob pattern="*.8[23569x]i" />
+ <glob pattern="*.9[2x]i" />
+ <glob pattern="*.v2i" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-range">
+ <comment xml:lang="en">Ti File (Range)</comment>
+ <comment xml:lang="fr">Fichier TI (Intervalle)</comment>
+ <glob pattern="*.8[56]r" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-real">
+ <comment xml:lang="en">Ti File (Real Number)</comment>
+ <comment xml:lang="fr">Fichier TI (Nombre Réel)</comment>
+ <glob pattern="*.73n" />
+ <glob pattern="*.8[2356x]n" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-string">
+ <comment xml:lang="en">Ti File (String)</comment>
+ <comment xml:lang="fr">Fichier TI (Chaîne)</comment>
+ <glob pattern="*.73s" />
+ <glob pattern="*.8[23569x]s" />
+ <glob pattern="*.9[2x]s" />
+ <glob pattern="*.v2s" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-table_setup">
+ <comment xml:lang="en">Ti File (Table Setup)</comment>
+ <comment xml:lang="fr">Fichier TI (Table Setup)</comment>
+ <glob pattern="*.73t" />
+ <glob pattern="*.8[2356x]t" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-text">
+ <comment xml:lang="en">Ti File (Text)</comment>
+ <comment xml:lang="fr">Fichier TI (Texte)</comment>
+ <glob pattern="*.89t" />
+ <glob pattern="*.9[2x]t" />
+ <glob pattern="*.v2t" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-tigroup">
+ <comment xml:lang="en">Ti File (TiGroup)</comment>
+ <comment xml:lang="fr">Fichier TI (TiGroup)</comment>
+ <glob pattern="*.tig" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+ <mime-type type="application/x-tilp-vector">
+ <comment xml:lang="en">Ti File (Vector)</comment>
+ <comment xml:lang="fr">Fichier TI (Vecteur)</comment>
+ <glob pattern="*.86v" />
+ <sub-class-of type="application/x-tilp" />
+ </mime-type>
+</mime-info>
+
+
+
+