summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2020-06-06 01:34:49 +0200
committerAntoine Viallon2020-06-06 01:35:37 +0200
commit0039a6146bf3a1c4dc6f0a7d6ffa026c1419ef85 (patch)
treee7287a64cac5551bf72fb98fac8c056c394a9731
downloadaur-0039a6146bf3a1c4dc6f0a7d6ffa026c1419ef85.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD55
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4066a53913b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = tilp-git
+ pkgdesc = TI graphing calculator link/transfer program
+ pkgver = 1.18.r25.g4fdd6bd0
+ pkgrel = 1
+ url = https://github.com/adriweb/tilp_and_gfm/tree/gtk3
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ depends = gtk3
+ depends = libticalcs
+ optdepends = gfm: to manage and manipulate TI Group Files (backups)
+ provides = tilp
+ conflicts = tilp
+ source = tilp-git::git+https://github.com/adriweb/tilp_and_gfm.git#branch=gtk3
+ md5sums = SKIP
+
+pkgname = tilp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e810e8a8b6d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Taylor Lookabaugh <jesus.christ.i.love@gmail.com>
+# Contributor: Jon Sturm <Jasturm002@aol.com>
+# Contributor: Scott Garrett <Wintervenom@archlinux.us>
+
+pkgname=tilp-git
+pkgver=1.18.r25.g4fdd6bd0
+pkgrel=1
+pkgdesc="TI graphing calculator link/transfer program"
+arch=('i686' 'x86_64')
+url="https://github.com/adriweb/tilp_and_gfm/tree/gtk3"
+license=('GPL2')
+depends=('gtk3' 'libticalcs')
+makedepends=('intltool')
+optdepends=('gfm: to manage and manipulate TI Group Files (backups)')
+source=("$pkgname::git+https://github.com/adriweb/tilp_and_gfm.git#branch=gtk3")
+md5sums=('SKIP')
+provides=('tilp')
+conflicts=('tilp')
+
+pkgver() {
+ cd "$pkgbase"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+prepare() {
+ #cd "${srcdir}/tilp2-${pkgver}"
+ cd "${srcdir}/${pkgname}/tilp/trunk"
+
+ #patch -Np1 < "${srcdir}/remove-broken-kde-support.patch"
+}
+
+build() {
+ #cd "${srcdir}/tilp2-${pkgver}"
+ cd "${srcdir}/${pkgname}/tilp/trunk"
+
+# mkdir -p build
+# cd build
+
+# cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+# cmake --build ..
+ autoreconf -ivf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/tilp/trunk"
+ #cd "${srcdir}/tilp2-${pkgver}"
+
+ #make --install ..
+ make install DESTDIR="${pkgdir}"
+}