summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Dobre2021-11-13 13:11:48 +0200
committerAndrei Dobre2021-11-13 13:11:48 +0200
commitbb801f3ec8bcae91558b49bf5da7bd4c67efccd7 (patch)
treed51859459c53ff56705ca28e3942a4341cb144d1
parentcc5378274fab79db9d82e4e72fa8dcb8117e357b (diff)
downloadaur-bb801f3ec8bcae91558b49bf5da7bd4c67efccd7.tar.gz
Update to 0.23.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 11 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea302698fbeb..376321830ab4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,12 @@
pkgbase = tilt
pkgdesc = Local Kubernetes development with no stress
- pkgver = 0.17.9
+ pkgver = 0.23.0
pkgrel = 1
url = https://github.com/windmilleng/tilt
arch = x86_64
license = Apache
- makedepends = go
- makedepends = nodejs
- makedepends = yarn
- optdepends = kubectl
conflicts = tilt-bin
- source = tilt-0.17.9.tar.gz::https://github.com/windmilleng/tilt/archive/v0.17.9.tar.gz
- sha256sums = 6630b5a80e5fec7d34e563db83b6533ed8114aa423f1a8c4154e90461d8858b6
+ source = https://github.com/tilt-dev/tilt/releases/download/v0.23.0/tilt.0.23.0.linux.x86_64.tar.gz
+ sha256sums = d94fcb44a8ff9599a653a5e6b7b3c34f99a4ac70ca64f8e6dfa3009f3fba4c5c
pkgname = tilt
-
diff --git a/PKGBUILD b/PKGBUILD
index 34dab1483864..87d3a3a864a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,17 @@
-# Maintainer: David Birks <david@birks.dev>
+# Maintainer: Andrei Dobre <andreidobre at gmail dot com>
+# Contributor: David Birks <david@birks.dev>
pkgname=tilt
-pkgdesc='Local Kubernetes development with no stress'
-pkgver=0.17.9
+pkgdesc="Local Kubernetes development with no stress"
+pkgver=0.23.0
pkgrel=1
arch=('x86_64')
license=('Apache')
-url='https://github.com/windmilleng/tilt'
-optdepends=('kubectl')
-makedepends=('go' 'nodejs' 'yarn')
+url="https://github.com/windmilleng/tilt"
conflicts=('tilt-bin')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/windmilleng/tilt/archive/v$pkgver.tar.gz")
-sha256sums=('6630b5a80e5fec7d34e563db83b6533ed8114aa423f1a8c4154e90461d8858b6')
-
-build() {
- cd $pkgname-$pkgver
-
- make ensure build build-js
-
- go build \
- -trimpath \
- -ldflags "-X main.version=$pkgver -X main.date=$(date --iso-8601)" \
- -o tilt \
- cmd/tilt/main.go
-}
+source=("https://github.com/tilt-dev/tilt/releases/download/v${pkgver}/tilt.${pkgver}.linux.x86_64.tar.gz")
+sha256sums=('d94fcb44a8ff9599a653a5e6b7b3c34f99a4ac70ca64f8e6dfa3009f3fba4c5c')
package() {
- install -Dm 755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 755 "${srcdir}/tilt" "${pkgdir}/usr/bin/tilt"
}