summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-05-21 00:05:44 +0800
committerChocobo12018-05-21 00:53:40 +0800
commit27a959dd19da8880d18aa1ddb95388342204960f (patch)
tree7c09bd61f694cb885ed5e69f5f4c0c4606c17bb4
downloadaur-27a959dd19da8880d18aa1ddb95388342204960f.tar.gz
newpkg: time-git 1.9.r1.g987d908-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..037615ea811b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = time-git
+ pkgdesc = Displays information about the resources used by other program
+ pkgver = 1.9.r1.g987d908
+ pkgrel = 1
+ url = https://www.gnu.org/software/time/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ provides = time
+ conflicts = time
+ source = git+https://git.savannah.gnu.org/git/time.git
+ sha256sums = SKIP
+
+pkgname = time-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3801683e804
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=time-git
+pkgver=1.9.r1.g987d908
+pkgrel=1
+pkgdesc="Displays information about the resources used by other program"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/time/"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git')
+provides=('time')
+conflicts=('time')
+source=("git+https://git.savannah.gnu.org/git/time.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "time"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "time"
+
+ ./bootstrap || ./bootstrap # workaround for faulty bootstrap script
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "time"
+
+ make check
+}
+
+package() {
+ cd "time"
+
+ make DESTDIR="$pkgdir" install
+}