summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-06 15:26:24 +0800
committerzxp198210052024-02-06 15:26:24 +0800
commit2d3d2132c198c7bf28c1a9e5b59bf9507b4cb7b0 (patch)
tree73c1f2674b65162519923687c8f745678d6665ad
parent714eb7ebc7f5f68e1edfd55b7acd7d0aa6799b19 (diff)
downloadaur-2d3d2132c198c7bf28c1a9e5b59bf9507b4cb7b0.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--time-to-leave.sh11
3 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49c4a5990d9a..48356654400b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = time-to-leave-bin
pkgdesc = Log work hours and get notified when it's time to leave the office and start to live.
pkgver = 3.0.0
- pkgrel = 2
+ pkgrel = 3
url = http://timetoleave.app/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
depends = electron11
provides = time-to-leave=3.0.0
conflicts = time-to-leave
source = time-to-leave-3.0.0.deb::https://github.com/thamara/time-to-leave/releases/download/3.0.0/time-to-leave-3.0.0-amd64.deb
source = time-to-leave.sh
sha256sums = cb545e917262e4263c59baa95a2b995d4aac7370bf623ce2b715d4b5d819f45a
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = time-to-leave-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2edd9cca993a..bf46dd0585be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=time-to-leave-bin
pkgver=3.0.0
_electronversion=11
-pkgrel=2
+pkgrel=3
pkgdesc="Log work hours and get notified when it's time to leave the office and start to live."
arch=('x86_64')
url="http://timetoleave.app/"
_ghurl="https://github.com/thamara/time-to-leave"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -18,11 +18,11 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('cb545e917262e4263c59baa95a2b995d4aac7370bf623ce2b715d4b5d819f45a'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.zst"
}
diff --git a/time-to-leave.sh b/time-to-leave.sh
index c77c53567639..f9ced1432cfc 100644
--- a/time-to-leave.sh
+++ b/time-to-leave.sh
@@ -1,17 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file