summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-23 10:09:30 +0800
committerzxp198210052024-01-23 10:09:30 +0800
commit35835659122ddf3494ee9af86589ff3d1622e68b (patch)
tree9f0169c308e080f45601f85b654adf4175ea3f5d
parent6052b729401bf44898f7c684eaf238978d6b36c0 (diff)
downloadaur-35835659122ddf3494ee9af86589ff3d1622e68b.tar.gz
fix errors
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--timecop.sh2
3 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 963bd951e7ec..3b613405eaa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = timecop-bin
pkgdesc = A time tracking app that respects your privacy and the gets the job done without being fancy.
pkgver = 1.8.0
- pkgrel = 5
+ pkgrel = 6
url = https://timecop.app/
arch = aarch64
arch = x86_64
- license = Apache
- depends = harfbuzz
+ license = Apache-2.0
depends = gdk-pixbuf2
- depends = cairo
- depends = pango
depends = hicolor-icon-theme
- depends = libepoxy
depends = at-spi2-core
depends = gtk3
provides = timecop=1.8.0
conflicts = timecop
source = timecop.sh
- sha256sums = 088686f54a6f4b05e34220f46f719786b48173234e14ed0fece3597e7484e72e
+ sha256sums = 87aad073913a72e5fa1c7f4e0f6f695dafc5ba8ea675a62be03c532c701c243a
source_aarch64 = timecop-1.8.0-aarch64.zip::https://github.com/hamaluik/timecop/releases/download/v1.8.0/timecop-linux-aarch64.tar.xz
sha256sums_aarch64 = cf376f25cde81d5299c4f543eee15380450470512630ae28697557ddea77bd47
source_x86_64 = timecop-1.8.0-x86_64.zip::https://github.com/hamaluik/timecop/releases/download/v1.8.0/timecop-linux-x86_64.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 13df01c409b9..b73f415120ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=timecop-bin
_appname=ca.hamaluik.Timecop
pkgver=1.8.0
-pkgrel=5
+pkgrel=6
pkgdesc='A time tracking app that respects your privacy and the gets the job done without being fancy.'
arch=(
'aarch64'
@@ -10,23 +10,19 @@ arch=(
)
url="https://timecop.app/"
_ghurl="https://github.com/hamaluik/timecop"
-license=('Apache')
+license=('Apache-2.0')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'harfbuzz'
'gdk-pixbuf2'
- 'cairo'
- 'pango'
'hicolor-icon-theme'
- 'libepoxy'
'at-spi2-core'
'gtk3'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-aarch64.tar.xz")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-x86_64.tar.xz")
source=("${pkgname%-bin}.sh")
-sha256sums=('088686f54a6f4b05e34220f46f719786b48173234e14ed0fece3597e7484e72e')
+sha256sums=('87aad073913a72e5fa1c7f4e0f6f695dafc5ba8ea675a62be03c532c701c243a')
sha256sums_aarch64=('cf376f25cde81d5299c4f543eee15380450470512630ae28697557ddea77bd47')
sha256sums_x86_64=('c2a00bdcb9a32eeaa566d0f1de4d1253460761abe358767209b441748818233c')
build() {
diff --git a/timecop.sh b/timecop.sh
index 52cd8c1d6b48..5f8466f8e866 100644
--- a/timecop.sh
+++ b/timecop.sh
@@ -5,4 +5,4 @@ _RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
cd "${_APPDIR}"
-exec "${_RUNNAME}" "$@" \ No newline at end of file
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file