summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-10 15:06:35 +0800
committerzxp198210052023-11-10 15:06:35 +0800
commit9bff02bfb3e0f00ab35b1b2f0ddf863cc60e112f (patch)
tree520d3d0c16811cdf1c5eda153d55d99a71e3283b
parent8338ceedae39be361c338c4dea19026bea7f44d2 (diff)
downloadaur-9bff02bfb3e0f00ab35b1b2f0ddf863cc60e112f.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 655128767769..60aa0faae394 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = timecop-bin
pkgdesc = A time tracking app that respects your privacy and the gets the job done without being fancy.
pkgver = 1.8.0
- pkgrel = 3
+ pkgrel = 4
url = https://timecop.app/
arch = aarch64
arch = x86_64
license = Apache
depends = harfbuzz
- depends = glib2
depends = gdk-pixbuf2
depends = cairo
depends = pango
@@ -15,8 +14,6 @@ pkgbase = timecop-bin
depends = libepoxy
depends = at-spi2-core
depends = gtk3
- depends = glibc
- depends = gcc-libs
provides = timecop=1.8.0
conflicts = timecop
source_aarch64 = timecop-1.8.0-aarch64.zip::https://github.com/hamaluik/timecop/releases/download/v1.8.0/timecop-linux-aarch64.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 4d2a7d8bef44..64d8cbd8f9a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,32 @@
pkgname=timecop-bin
_appname=ca.hamaluik.Timecop
pkgver=1.8.0
-pkgrel=3
+pkgrel=4
pkgdesc='A time tracking app that respects your privacy and the gets the job done without being fancy.'
-arch=('aarch64' 'x86_64')
+arch=(
+ 'aarch64'
+ 'x86_64'
+)
url="https://timecop.app/"
-_githuburl="https://github.com/hamaluik/timecop"
+_ghurl="https://github.com/hamaluik/timecop"
license=('Apache')
-depends=('harfbuzz' 'glib2' 'gdk-pixbuf2' 'cairo' 'pango' 'hicolor-icon-theme' 'libepoxy' 'at-spi2-core' 'gtk3' 'glibc' 'gcc-libs')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-aarch64.tar.xz")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-x86_64.tar.xz")
+depends=(
+ 'harfbuzz'
+ 'gdk-pixbuf2'
+ 'cairo'
+ 'pango'
+ 'hicolor-icon-theme'
+ 'libepoxy'
+ 'at-spi2-core'
+ 'gtk3'
+)
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-aarch64.tar.xz")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-x86_64.tar.xz")
sha256sums_aarch64=('cf376f25cde81d5299c4f543eee15380450470512630ae28697557ddea77bd47')
sha256sums_x86_64=('c2a00bdcb9a32eeaa566d0f1de4d1253460761abe358767209b441748818233c')
-prepare() {
+build() {
sed "s|${_appname}|${pkgname%-bin}|g" -i "${srcdir}/${pkgname%-bin}-linux-${CARCH}/${_appname}.desktop"
}
package() {