summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-04 16:16:25 +0800
committerzxp198210052023-07-04 16:16:25 +0800
commitb34cfc1aeb894f78b0482ea694fff8e2c0db93d5 (patch)
tree28bba41fc460692fa67c461a499ef337edde3a9b
downloadaur-b34cfc1aeb894f78b0482ea694fff8e2c0db93d5.tar.gz
first release
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD24
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6785eb789a65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = timecop-bin
+ pkgdesc = A time tracking app that respects your privacy and the gets the job done without being fancy.
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://timecop.app/
+ arch = aarch64
+ arch = x86_64
+ license = Apache
+ depends = harfbuzz
+ depends = glib2
+ depends = gdk-pixbuf2
+ depends = cairo
+ depends = pango
+ depends = hicolor-icon-theme
+ depends = libepoxy
+ depends = at-spi2-core
+ depends = gtk3
+ depends = glibc
+ depends = gcc-libs
+ conflicts = timecop
+ conflicts = timecop-appimage
+ source_aarch64 = timecop-1.8.0-aarch64.zip::https://github.com/hamaluik/timecop/releases/download/v1.8.0/timecop-linux-aarch64.tar.xz
+ sha256sums_aarch64 = cf376f25cde81d5299c4f543eee15380450470512630ae28697557ddea77bd47
+ source_x86_64 = timecop-1.8.0-x86_64.zip::https://github.com/hamaluik/timecop/releases/download/v1.8.0/timecop-linux-x86_64.tar.xz
+ sha256sums_x86_64 = c2a00bdcb9a32eeaa566d0f1de4d1253460761abe358767209b441748818233c
+
+pkgname = timecop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..104f73b6ad61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="timecop-bin"
+_appname="ca.hamaluik.Timecop"
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='A time tracking app that respects your privacy and the gets the job done without being fancy.'
+arch=('aarch64' 'x86_64')
+url="https://timecop.app/"
+_githuburl="https://github.com/hamaluik/timecop"
+license=('Apache')
+depends=('harfbuzz' 'glib2' 'gdk-pixbuf2' 'cairo' 'pango' 'hicolor-icon-theme' 'libepoxy' 'at-spi2-core' 'gtk3' 'glibc' 'gcc-libs')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-aarch64.tar.xz")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-x86_64.tar.xz")
+sha256sums_aarch64=('cf376f25cde81d5299c4f543eee15380450470512630ae28697557ddea77bd47')
+sha256sums_x86_64=('c2a00bdcb9a32eeaa566d0f1de4d1253460761abe358767209b441748818233c')
+package() {
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
+ cp -r "${srcdir}/${pkgname%-bin}-linux-${CARCH}/bin/"* "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-linux-${CARCH}/${_appname}.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname%-bin}.svg"
+ sed "s|Exec=${pkgname%-bin}|Exec=/opt/${pkgname%-bin}/${pkgname%-bin}|g;s|${_appname}|${pkgname%-bin}|g" -i "${srcdir}/${pkgname%-bin}-linux-${CARCH}/${_appname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-linux-${CARCH}/${_appname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-linux-${CARCH}/${_appname}.appdata.xml" "${pkgdir}/usr/share/appdata/${pkgname%-bin}.appdata.xml"
+} \ No newline at end of file