summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkolorafa2016-05-15 12:50:41 +0200
committerkolorafa2016-05-15 12:50:41 +0200
commitd664f7d97d8cae7ab423a3c6159698df09a196e6 (patch)
treed55532427ae76aa28f8245ba857c31d4fb03dadc
downloadaur-d664f7d97d8cae7ab423a3c6159698df09a196e6.tar.gz
Rafał
said 12 days ago (...) When i will be installing it would be nice to have AUR package, maybe i will create one if that's ok with you :) Have a nice day :) Anton said 12 days ago Hi Rafal, I'm glad that it's working for you now. You can create AUR package. Let me know if you have any other questions. Best regards, Anton Time Doctor Support
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee0f58b6d146
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = timedoctorpro
+ pkgdesc = App to track work time from timedoctor.com
+ pkgver = 1.4.74.11
+ pkgrel = 1
+ url = https://www.timedoctor.com/download.html
+ arch = x86_64
+ license = proprietary
+ depends = libxss
+ depends = intel-tbb
+ depends = opencv2
+ optdepends = openexr
+ source = https://updates.timedoctor.com/download/_production/tdpro/linux-ubuntu-16.04/timedoctorpro_1.4.74-11ubuntu16.04_amd64.deb
+ md5sums = 2883fbcf495d9657a9fa8c9c64595b1b
+
+pkgname = timedoctorpro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a3d540b9904
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=timedoctorpro
+pkgver=1.4.74.11
+pkgrel=1
+arch=('x86_64')
+pkgdesc="App to track work time from timedoctor.com"
+url="https://www.timedoctor.com/download.html"
+license=('proprietary')
+#mayybe also depends=('openexr')
+depends=('libxss' 'intel-tbb' 'opencv2')
+optdepends=('openexr')
+
+#install=$pkgname.install
+source=('https://updates.timedoctor.com/download/_production/tdpro/linux-ubuntu-16.04/timedoctorpro_1.4.74-11ubuntu16.04_amd64.deb')
+md5sums=('2883fbcf495d9657a9fa8c9c64595b1b')
+
+
+package() {
+ cd $pkgdir
+ tar -xf $srcdir/data.tar.xz
+}