summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortuxflo2016-03-15 16:47:35 +0100
committertuxflo2016-03-15 16:47:35 +0100
commitdfd6a19349846dc61eb6b676aa8779eae84b9b61 (patch)
treeecb263dc68145771d8ff7a3343655de042a7fac2
downloadaur-dfd6a19349846dc61eb6b676aa8779eae84b9b61.tar.gz
initial commit, add PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cf8be5a93dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Mar 15 15:47:18 UTC 2016
+pkgbase = timekeeper-git
+ pkgdesc = Plasma time tracking applet
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/grulja/plasma-timekeeper
+ arch = i686
+ arch = x86_64
+ license = gpl-2.0
+ depends = cmake
+ depends = plasma-desktop
+ source = timekeeper::git+https://github.com/grulja/plasma-timekeeper
+ md5sums = SKIP
+
+pkgname = timekeeper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abd5a45ec5a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: tuxflo
+
+pkgname=timekeeper-git
+pkgver=1
+pkgrel=1
+pkgdesc="Plasma time tracking applet"
+arch=('i686' 'x86_64')
+url="https://github.com/grulja/plasma-timekeeper"
+license=('gpl-2.0')
+depends=('cmake' 'plasma-desktop')
+source=('timekeeper::git+https://github.com/grulja/plasma-timekeeper')
+
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/timekeeper"
+ mkdir "${srcdir}/timekeeper/build"
+ cd "${srcdir}/timekeeper/build"
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DQML_INSTALL_DIR:PATH="/usr/lib/qt/qml"
+ make
+}
+
+package() {
+ #install -dm755 "${pkgdir}/usr/bin"
+ cd "${srcdir}/${pgkname}/timekeeper/build"
+ make DESTDIR="$pkgdir/" install
+}