summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Morr2018-09-06 11:35:27 +0200
committerSebastian Morr2018-09-06 11:35:27 +0200
commit0f225265c59e10324d49ddb3840696326922feea (patch)
tree56c0a631e139cfd3d96760fe85a5f2702a66b5a6
downloadaur-0f225265c59e10324d49ddb3840696326922feea.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d3fdd526e23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Sep 6 09:34:58 UTC 2018
+pkgbase = timelens
+ pkgdesc = Creates visual timelines from video files, to visualize color development. Inspired by the moviebarcode tumblr.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/timelens/timelens
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = rust
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = gst-libav
+ provides = timelens
+ conflicts = timelens
+ source = https://github.com/timelens/timelens/archive/0.1.0.tar.gz
+ md5sums = 81612aca6ccb386c808cda4ffe0af7a7
+
+pkgname = timelens
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edab89bb1264
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sebastian Morr <sebastian@morr.cc>
+
+pkgname=timelens
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Creates visual timelines from video files, to visualize color development. Inspired by the moviebarcode tumblr."
+arch=('i686' 'x86_64')
+url="https://github.com/timelens/timelens"
+license=('GPL')
+provides=('timelens')
+conflicts=('timelens')
+depends=('gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav')
+makedepends=('git' 'rust')
+source=(https://github.com/timelens/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('81612aca6ccb386c808cda4ffe0af7a7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/timelens" "$pkgdir/usr/bin/timelens"
+}