summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:39:54 +0200
committerSanskritFritz2015-06-14 00:39:54 +0200
commitc3366d6be9a822ab31a3f4b000c6ead992be843a (patch)
tree1fc300a714cd510aff57806986f1907baf4bf11a
downloadaur-c3366d6be9a822ab31a3f4b000c6ead992be843a.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--makefile_arch.patch11
-rw-r--r--timeoutd.service11
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56ee597c61cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = timeoutd
+ pkgdesc = Flexible user timeout daemon. Enforces user login restrictions.
+ pkgver = 1.5deb10.1
+ pkgrel = 2
+ url = http://packages.debian.org/squeeze/timeoutd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libx11
+ depends = libxext
+ depends = libxss
+ backup = etc/timeouts
+ source = http://ftp.de.debian.org/debian/pool/main/t/timeoutd/timeoutd_1.5.orig.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/t/timeoutd/timeoutd_1.5-10.1.diff.gz
+ source = makefile_arch.patch
+ source = timeoutd.service
+ md5sums = 0be669e0111575fc5bbc8f20e27e4f88
+ md5sums = 2c1ecc3417d81cda99705078244bd3e7
+ md5sums = 6f8a7ac7b8abdd40f04264ad132a81e6
+ md5sums = 8ced5cbe1e96e0f35e240858c1b21fb6
+
+pkgname = timeoutd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71eec0547bc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=timeoutd
+pkgver=1.5deb10.1
+pkgrel=2
+pkgdesc="Flexible user timeout daemon. Enforces user login restrictions."
+arch=('i686' 'x86_64')
+url="http://packages.debian.org/squeeze/timeoutd"
+license=('GPL')
+depends=('libx11' 'libxext' 'libxss')
+backup=('etc/timeouts')
+source=('http://ftp.de.debian.org/debian/pool/main/t/timeoutd/timeoutd_1.5.orig.tar.gz'
+ 'http://ftp.de.debian.org/debian/pool/main/t/timeoutd/timeoutd_1.5-10.1.diff.gz'
+ 'makefile_arch.patch'
+ 'timeoutd.service')
+
+build() {
+ cd "$srcdir/timeoutd-1.5.orig"
+ patch -p1 < "../timeoutd_1.5-10.1.diff"
+ patch -p0 < "$srcdir/makefile_arch.patch"
+ make
+}
+
+package() {
+ cd "$srcdir/timeoutd-1.5.orig"
+ install -Dm0755 timeoutd "$pkgdir/usr/bin/timeoutd"
+ install -Dm0644 timeouts "$pkgdir/etc/timeouts"
+ install -Dm0644 timeoutd.8 "$pkgdir/usr/share/man/man8/timeoutd.8"
+ install -Dm0644 timeouts.5 "$pkgdir/usr/share/man/man5/timeouts.5"
+ cd "$srcdir"
+ install -Dm0644 timeoutd.service "$pkgdir/usr/lib/systemd/system/timeoutd.service"
+}
+
+md5sums=('0be669e0111575fc5bbc8f20e27e4f88'
+ '2c1ecc3417d81cda99705078244bd3e7'
+ '6f8a7ac7b8abdd40f04264ad132a81e6'
+ '8ced5cbe1e96e0f35e240858c1b21fb6')
+
diff --git a/makefile_arch.patch b/makefile_arch.patch
new file mode 100644
index 000000000000..7579becf2ddc
--- /dev/null
+++ b/makefile_arch.patch
@@ -0,0 +1,11 @@
+--- Makefile 2012-10-29 16:51:14.540335584 +0100
++++ Makefile.new 2012-10-29 16:54:26.742910007 +0100
+@@ -2,7 +2,7 @@
+ timeoutd: timeoutd.c Makefile
+ #$(CC) $(CFLAGS) -o timeoutd timeoutd.c
+ $(CC) $(CFLAGS) -o timeoutd.o -c timeoutd.c -DTIMEOUTDX11
+- $(CC) $(CFLAGS) -o timeoutd -L/usr/X11R6/lib timeoutd.o -lXss -lXext
++ $(CC) $(CFLAGS) -o timeoutd -L/usr/lib timeoutd.o -lXss -lXext -lX11
+
+
+ install:
diff --git a/timeoutd.service b/timeoutd.service
new file mode 100644
index 000000000000..55ba1976c3c0
--- /dev/null
+++ b/timeoutd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Flexible user timeout daemon
+
+[Service]
+Type=forking
+GuessMainPID=yes
+ExecStart=/usr/bin/timeoutd
+ExecStop=pkill timeoutd
+
+[Install]
+WantedBy=multi-user.target