summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPando852021-12-07 03:46:57 +0100
committerPando852021-12-07 04:09:49 +0100
commit93d57a6a39e6269005c7cdea2fed4d374e9ac9aa (patch)
treec033dc3eea0d57f9ceb76e36c24a50b36c8e0aac
downloadaur-93d57a6a39e6269005c7cdea2fed4d374e9ac9aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..838b587ec588
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = timer-rs
+ pkgdesc = Simple countdown terminal alarm
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/pando85/timer
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL
+ makedepends = cargo
+ makedepends = git
+ depends = gcc-libs
+ depends = alsa-lib
+ source = git+https://github.com/pando85/timer.git#tag=v0.1.2?signed
+ validpgpkeys = C15CDDF9318F14398300B917C6CB8A1793CA3F94
+ sha512sums = SKIP
+
+pkgname = timer-rs
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fb8150092c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Pando85 <pando855@gmail.com>
+
+# https://github.com/orhun/pkgbuilds
+
+pkgname=timer-rs
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Simple countdown terminal alarm"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/pando85/timer"
+license=('GPL')
+depends=('gcc-libs'
+ 'alsa-lib')
+makedepends=('cargo'
+ 'git')
+source=("git+$url.git#tag=v${pkgver}?signed")
+validpgpkeys=('C15CDDF9318F14398300B917C6CB8A1793CA3F94')
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/timer"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$srcdir/timer"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$srcdir/timer"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$srcdir/timer"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/timer"
+}