summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-11-28 21:40:23 -0700
committerMark Wagie2020-11-28 21:40:23 -0700
commit25315074629ad76481f99eb58f5f0057affb831f (patch)
tree84ef4baa2e07baa3d1668091348da6e0ed0d768f
parent49250a47d57540adde437175330454add76ca854 (diff)
downloadaur-25315074629ad76481f99eb58f5f0057affb831f.tar.gz
20.11.1
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD93
-rw-r--r--pr476.patch15
-rw-r--r--timeshift.install (renamed from timeshift-install.sh)0
5 files changed, 36 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb03420c8fae..e630bd10390b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,28 @@
-# Generated by mksrcinfo v8
-# Fri Mar 13 01:02:24 UTC 2020
pkgbase = timeshift
pkgdesc = A system restore utility for Linux
- pkgver = 20.03
+ pkgver = 20.11.1
pkgrel = 1
url = https://github.com/teejee2008/timeshift
- install = timeshift-install.sh
+ install = timeshift.install
arch = i686
arch = x86_64
license = GPL
makedepends = vala
makedepends = diffutils
makedepends = coreutils
- makedepends = vte3
+ makedepends = xapp=1.8.10
depends = gtk3
depends = libsoup
depends = desktop-file-utils
+ depends = cronie
depends = rsync
- depends = libgee>=0.18.0
- depends = json-glib
+ depends = libgee
depends = vte3
- depends = xapps
- optdepends = cronie: scheduling
- optdepends = gksu: run timeshift from a menu
- options = !emptydirs
- source = timeshift_v20.03.tgz::https://github.com/teejee2008/timeshift/archive/v20.03.tar.gz
- source = pr476.patch
- md5sums = 5d1022c1466bb093b0a4562b6f0e11ea
- md5sums = 84164d8ff50bd28cc8d534272d363ef4
- sha256sums = 6516150481fc3e69c090ff25426e85d99d10035949446368918076b19335b391
- sha256sums = 6a4889a8923c0752e024eea2a30416185ebfe236231cf387a5576810b6ad6de0
+ depends = xapp
+ depends = xorg-xhost
+ depends = btrfs-progs
+ source = timeshift-20.11.1.tar.gz::https://github.com/teejee2008/timeshift/archive/v20.11.1.tar.gz
+ sha256sums = c6dcca80b42f80a8c8d9d03e91eb17aa634be2f1031f667bba3f483410297abb
pkgname = timeshift
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aec8fd5d8395
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!timeshift.install
diff --git a/PKGBUILD b/PKGBUILD
index fe3989cc6007..9481af2eca0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,86 +1,29 @@
-# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Maintainer: librewish <librewish at gmail dot com>
+# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: Jay Garcia <morbidj at gmail dot com>
# Contributor: Doug Newgard <scimmia22 at outlook dot com>
# Contributor: Robert Orzanna <orschiro at gmail dot com>
-
-set -u
-
-#_ubver='1.7.2~174~ubuntu14.04.1'; _libgee='libgee06' # This won't build with vala=0.12 or vala=0.28.0
-#_ubver='1.7.3~177~ubuntu15.10.1' # not found
-#_ubver='1.7.3~177~ubuntu15.04.1' # not found
-#_ubver='1.7.3~177~ubuntu14.04.1'; _libgee='libgee>=0.18.0'
-#_ubver='1.7.5~180~ubuntu14.04.1'; _libgee='libgee>=0.18.0'
-#_ubver='1.7.6~184~ubuntu14.04.1'; _libgee='libgee>=0.18.0'
-#_ubver='17.2'; _ubrel='429'; _libgee='libgee>=0.18.0'
-#_ubver='17.11'; _libgee='libgee>=0.18.0'
-#_ubver='18.1'; _libgee='libgee>=0.18.0'
-#_ubver='18.1.1'; _libgee='libgee>=0.18.0'
-#_ubver='18.4'; _libgee='libgee>=0.18.0'
-#_ubver='18.6.1'; _libgee='libgee>=0.18.0'
-#_ubver='18.8'; _libgee='libgee>=0.18.0'
-#_ubver='18.9.1'; _libgee='libgee>=0.18.0'
-#_ubver='19.01'; _libgee='libgee>=0.18.0'
-#_ubver='19.08.1'; _libgee='libgee>=0.18.0'
-_ubver='20.03'; _libgee='libgee>=0.18.0'
-pkgname='timeshift'
-pkgver="${_ubver}"
-pkgrel='1'
-pkgdesc='A system restore utility for Linux'
+pkgname=timeshift
+pkgver=20.11.1
+pkgrel=1
+pkgdesc="A system restore utility for Linux"
arch=('i686' 'x86_64')
-#url='https://launchpad.net/~teejee2008/+archive/ubuntu/ppa'
-#url='https://code.launchpad.net/~teejee2008/timeshift'
-#url='https://launchpad.net/timeshift'
-url='https://github.com/teejee2008/timeshift'
+url="https://github.com/teejee2008/timeshift"
license=('GPL')
-_arch_depends=('rsync' 'libgee06' 'json-glib') # from installer/install.sh
-_arch_depends[1]="${_libgee}"
-depends=('gtk3' 'libsoup' 'desktop-file-utils' "${_arch_depends[@]}" 'vte3' 'xapps')
-unset _arch_depends
-optdepends=(
- 'cronie: scheduling'
- 'gksu: run timeshift from a menu'
-)
-makedepends=('vala' 'diffutils' 'coreutils' 'vte3')
-options=('!emptydirs')
-install="${pkgname}-install.sh"
-#_verwatch=("${url//code/bazaar}/trunk/changes" 'v\([0-9\.]\+\)' 't')
-#source=("${url}/+files/${_srcdir}.tar.gz")
-#_srcdir='~teejee2008/timeshift/trunk'
-#source=("timeshift_v${_ubver}_r${_ubrel}.tgz::${url//code/bazaar}/trunk/tarball/${_ubrel}")
-_github='teejee2008'
-_verwatch=("https://github.com/${_github}/${pkgname}/releases.atom" '\s\+<title>Timeshift v\([0-9\.]\+\)</title>.*' 'f')
-_srcdir="${pkgname}-${pkgver}"
-source=(
- "${pkgname}_v${pkgver}.tgz::https://github.com/${_github}/${pkgname}/archive/v${pkgver}.tar.gz"
- 'pr476.patch'
-)
-md5sums=('5d1022c1466bb093b0a4562b6f0e11ea'
- '84164d8ff50bd28cc8d534272d363ef4')
-sha256sums=('6516150481fc3e69c090ff25426e85d99d10035949446368918076b19335b391'
- '6a4889a8923c0752e024eea2a30416185ebfe236231cf387a5576810b6ad6de0')
-#sha256sums[0]='SKIP'
-
-prepare() {
- set -u
- cd "${_srcdir}"
- # ndowens04 2019-01-30 02:45
- #sed -e 's:--thread:& Core/AppExcludeEntry.vala:' -i 'src/makefile'
-
- #cp -p src/Utility/AsyncTask.vala{,.orig}
- #diff -pNau5 src/Utility/AsyncTask.vala{.orig,} > 'pr476.patch'
- #patch -Nbup0 -i "${srcdir}/pr476.patch"
- set +u
-}
+depends=('gtk3' 'libsoup' 'desktop-file-utils' 'cronie' 'rsync' 'libgee' 'vte3'
+ 'xapp' 'xorg-xhost' 'btrfs-progs')
+makedepends=('vala' 'diffutils' 'coreutils' 'xapp=1.8.10')
+install="$pkgname.install"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('c6dcca80b42f80a8c8d9d03e91eb17aa634be2f1031f667bba3f483410297abb')
build() {
- set -u
- make -C "${_srcdir}" -s -j1
- set +u
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- set -u
- make -C "${_srcdir}" -j1 DESTDIR="${pkgdir}" install
- set +u
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
}
-set +u
diff --git a/pr476.patch b/pr476.patch
deleted file mode 100644
index 6792adb235e9..000000000000
--- a/pr476.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/Utility/AsyncTask.vala.orig 2019-08-11 09:51:26.000000000 -0400
-+++ src/Utility/AsyncTask.vala 2019-09-28 18:51:54.005772803 -0400
-@@ -71,11 +71,11 @@ public abstract class AsyncTask : GLib.O
- // signals
- public signal void stdout_line_read(string line);
- public signal void stderr_line_read(string line);
- public signal void task_complete();
-
-- public AsyncTask(){
-+ protected AsyncTask(){
- working_dir = TEMP_DIR + "/" + timestamp_for_path();
- script_file = path_combine(working_dir, "script.sh");
- log_file = path_combine(working_dir, "task.log");
-
- //regex = new Gee.HashMap<string,Regex>(); // needs to be initialized again in instance constructor
diff --git a/timeshift-install.sh b/timeshift.install
index bc3bd2167015..bc3bd2167015 100644
--- a/timeshift-install.sh
+++ b/timeshift.install