summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-11-07 11:24:01 -0700
committerMark Wagie2022-11-07 11:24:01 -0700
commit4e879d66e3062373cfb2c143143aa5db9da0012e (patch)
tree75c13042e9114e51eb53c6c76e70633771964a7a
parent2f842f677a852ae477a6939536d9155b97e6805f (diff)
downloadaur-4e879d66e3062373cfb2c143143aa5db9da0012e.tar.gz
bump to master.mint21 tag
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 886f3d338418..5a5f44531862 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = timeshift
pkgdesc = A system restore utility for Linux
- pkgver = 22.06.5
- pkgrel = 2
+ pkgver = 22.06.5+12+g92ad80c
+ pkgrel = 1
url = https://github.com/linuxmint/timeshift
install = timeshift.install
arch = i686
@@ -25,7 +25,7 @@ pkgbase = timeshift
depends = xorg-xhost
optdepends = btrfs-progs: BTRFS support
optdepends = grub-btrfs: BTRFS snapshots in grub
- source = git+https://github.com/linuxmint/timeshift.git#commit=dad9aeb520554b72763c8f016f213077ee71ba55
+ source = git+https://github.com/linuxmint/timeshift.git#commit=92ad80cb0fba0520846108b021022dfbfd807335
source = snapshot-detect.desktop
source = snapshot-detect
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 95ada7f2fd4a..e45650870a1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Doug Newgard <scimmia22 at outlook dot com>
# Contributor: Robert Orzanna <orschiro at gmail dot com>
pkgname=timeshift
-pkgver=22.06.5
-pkgrel=2
+pkgver=22.06.5+12+g92ad80c
+pkgrel=1
pkgdesc="A system restore utility for Linux"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/linuxmint/timeshift"
@@ -18,7 +18,7 @@ checkdepends=('appstream-glib' 'desktop-file-utils')
optdepends=('btrfs-progs: BTRFS support'
'grub-btrfs: BTRFS snapshots in grub')
install="$pkgname.install"
-_commit=dad9aeb520554b72763c8f016f213077ee71ba55
+_commit=92ad80cb0fba0520846108b021022dfbfd807335 # tags/master.mint21
source=("git+https://github.com/linuxmint/timeshift.git#commit=$_commit"
# "read-only-btrfs-snapshot.patch"
"snapshot-detect.desktop"
@@ -29,17 +29,15 @@ sha256sums=('SKIP'
pkgver() {
cd "$srcdir/$pkgname"
- git describe --tags | sed 's/^v//;s/-/+/g'
+ git describe --tags --exclude master* | sed 's/^v//;s/-/+/g'
}
prepare() {
cd "$srcdir/$pkgname"
- # Use -Os for compilation instead of -O3
- git fetch https://github.com/teejee2008/timeshift.git && git cherry-pick -n 2d52682 --no-commit
-
- # #939, #937: Fix crash on ArchLinux and Ubuntu 22.10 Kinetic
- git fetch https://github.com/teejee2008/timeshift.git && git cherry-pick -n 5a78bb7 --no-commit
+ # Recursive make commands should always use the variable MAKE, not the explicit command name make
+ # https://real-world-systems.com/docs/make.1.html#SEC59
+ sed -i 's/make/$(MAKE)/g' makefile
# https://github.com/teejee2008/timeshift/pull/685
#patch -Np1 -i "$srcdir"/read-only-btrfs-snapshot.patch
@@ -48,7 +46,7 @@ prepare() {
build() {
export CFLAGS="${CFLAGS} --std=c99"
- cd "$srcdir/$pkgname/src"
+ cd "$srcdir/$pkgname"
make app-gtk
make app-console
}