summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2022-11-06 23:38:45 +0100
committerMattia Borda2022-11-06 23:38:45 +0100
commitb493db937ecd98470f87a4c3213e3f6364c5a051 (patch)
tree20ed13a09ae701a1b9c91e59d8c327d2182e6859
downloadaur-b493db937ecd98470f87a4c3213e3f6364c5a051.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e07cb513fac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = timeswitch-git
+ pkgdesc = Power off, reboot, suspend or send a notification on timer.
+ pkgver = 0.1.1.r1.gce836d6
+ pkgrel = 1
+ url = https://github.com/fsobolev/timeswitch
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = gtk4
+ depends = libadwaita
+ depends = python
+ depends = python-gobject
+ provides = timeswitch
+ conflicts = timeswitch
+ source = git+https://github.com/fsobolev/timeswitch.git
+ b2sums = SKIP
+
+pkgname = timeswitch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b050a34a50f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
+
+pkgname=timeswitch-git
+pkgver=0.1.1.r1.gce836d6
+pkgrel=1
+pkgdesc='Power off, reboot, suspend or send a notification on timer.'
+arch=(any)
+url=https://github.com/fsobolev/${pkgname%-git}
+license=(MIT)
+depends=(gtk4 libadwaita python python-gobject)
+makedepends=(git meson)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+$url.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson ${pkgname%-git} build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm644 ${pkgname%-git}/COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
+}