summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-06-15 11:04:37 -0500
committerLuis Martinez2021-06-15 11:04:37 -0500
commit6892def8aad7d6713b95417607f214524d042555 (patch)
tree844858126bda2eb7005ed4148e718f09f8dca08a
parentdd4a74d87e715e4eb83b23e078cc507c15cd3f63 (diff)
downloadaur-6892def8aad7d6713b95417607f214524d042555.tar.gz
update to 0.10.0
-rw-r--r--CHANGELOG.md11
-rw-r--r--PKGBUILD4
-rw-r--r--timetrace.install9
3 files changed, 21 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 524d2869dbca..72921a98f03c 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,17 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+## [0.10.0] - 2021-06-15
+
+### Added
+* Add `--output` flag for `timetrace status` (#129)
+* Add `--format` flag for `timetrace status` (#114, #123, #124)
+* Add Starship support
+* Add Scoop support
+
+### Changed
+* Remove seconds from printed durations (#113)
+
## [0.9.0] - 2021-06-09
### Added
diff --git a/PKGBUILD b/PKGBUILD
index 80a20efae443..f6c1cfe8bf1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
pkgname=timetrace
-pkgver=0.9.0
+pkgver=0.10.0
pkgrel=1
pkgdesc="A simple time-tracking CLI tool"
arch=('x86_64')
@@ -12,7 +12,7 @@ makedepends=('go')
install="$pkgname.install"
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('75fd7c2ac04a01ae699dfa2f3d4087bbc0c5c6a9203261920baf5c718d95a59c')
+sha256sums=('b2e29318e6c4cd4b2d062bc03ebb1731f57b4dec4b3336bb18047ddd4f5f6ad1')
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
diff --git a/timetrace.install b/timetrace.install
index 1906b3adb99f..0042f4a9db90 100644
--- a/timetrace.install
+++ b/timetrace.install
@@ -1,3 +1,10 @@
post_install() {
- printf ":: You can create a custom config under \$HOME/.timetrace/config.yaml\n"
+ echo ":: You can create a custom config under \$HOME/.timetrace/config.yaml"
+ echo ":: Check upstream documentation for more information."
+ echo ":: A copy has been installed under /usr/share/doc/timetrace/README.md for your reference."
+}
+
+post_upgrade() {
+ echo ":: Don't forget to check the changelog for any possible breaking changes!"
+ echo ":: You can do so with 'pacman -Qc timeshift'"
}