summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-06-04 18:31:06 -0500
committerLuis Martinez2021-06-04 18:31:06 -0500
commitae63c3063747112436b0d1100990f2bb866a140c (patch)
tree7b9d2b8e030b96c3917af0c5521cee5001a607d7
parentf589c2a9254d5eec9a867656ffa36f93276a0919 (diff)
downloadaur-ae63c3063747112436b0d1100990f2bb866a140c.tar.gz
update to 0.7.2
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md10
-rw-r--r--PKGBUILD4
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 115f2a896a79..0beb621d5260 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = timetrace
pkgdesc = A simple time-tracking CLI tool
- pkgver = 0.7.1
+ pkgver = 0.7.2
pkgrel = 1
url = https://github.com/dominikbraun/timetrace
install = timetrace.install
@@ -9,7 +9,7 @@ pkgbase = timetrace
license = Apache
makedepends = go
depends = glibc
- source = timetrace-0.7.1.tar.gz::https://github.com/dominikbraun/timetrace/archive/refs/tags/v0.7.1.tar.gz
- sha256sums = 3d32380e3f7f989511aa662ac63c20a8b69d22d40aec2b1dff943394c2c32b04
+ source = timetrace-0.7.2.tar.gz::https://github.com/dominikbraun/timetrace/archive/refs/tags/v0.7.2.tar.gz
+ sha256sums = dd9d8940d60e141f03d2ea87328f7bbf3f825e31fa5d6ff627b13704d11f8f04
pkgname = timetrace
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ce994ceab425..c1236572313f 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,7 +5,15 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
-## [Unreleased]
+## [0.7.2] - 2021-06-04
+
+### Fixed
+* Fix critical error when starting tracking if there are no existing records (#103)
+
+## [0.7.1] - 2021-06-02
+
+### Fixed
+* Fix unhandled error in `edit record` command if there are no tracked records (#96)
## [0.7.0] - 2021-05-30
diff --git a/PKGBUILD b/PKGBUILD
index 2b895617f4fb..4853c0bac2a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
pkgname=timetrace
-pkgver=0.7.1
+pkgver=0.7.2
pkgrel=1
pkgdesc="A simple time-tracking CLI tool"
arch=('x86_64')
@@ -12,7 +12,7 @@ makedepends=('go')
install="$pkgname.install"
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('3d32380e3f7f989511aa662ac63c20a8b69d22d40aec2b1dff943394c2c32b04')
+sha256sums=('dd9d8940d60e141f03d2ea87328f7bbf3f825e31fa5d6ff627b13704d11f8f04')
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"