summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-19 23:39:59 -0500
committerLuis Martinez2021-05-19 23:39:59 -0500
commitc82cdb54ad3526eb2c46062684f42df39a1039b3 (patch)
treeedfb3ba08d90c6ed00937cd3501e3d7c9a1748d3
downloadaur-c82cdb54ad3526eb2c46062684f42df39a1039b3.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--CHANGELOG.md59
-rw-r--r--PKGBUILD44
-rw-r--r--timetrace.install3
4 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57b5a314d0c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = timetrace
+ pkgdesc = A simple time-tracking CLI tool
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/dominikbraun/timetrace
+ install = timetrace.install
+ changelog = CHANGELOG.md
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ depends = glibc
+ source = timetrace-0.3.1.tar.gz::https://github.com/dominikbraun/timetrace/archive/refs/tags/v0.3.1.tar.gz
+ sha256sums = 5655bcdc70926b07556d79d0edbdace3d04976c888460011b59c34a552f1ed0e
+
+pkgname = timetrace
+
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..16ca58a1c5cc
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,59 @@
+# Changelog
+
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
+and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+
+## [Unreleased]
+
+## [0.3.1] - 2021-05-18
+
+### Changed
+* Introduce the `today` and `yesterday` aliases for `timetrace list records` (#32)
+* Preview the target record and ask for confirmation when deleting a record (#37)
+
+## [0.3.0] - 2021-05-17
+
+### Added
+* `timetrace delete record` command (#22)
+
+### Changed
+* Add project name to the output of `list records` (#24)
+
+## [0.2.1] - 2021-05-16
+
+### Changed
+* Beautified output of time durations (#20)
+
+### Fixed
+* Fix `timetrace status` if there was no time tracking yet (#18)
+
+## [0.2.0] - 2021-05-16
+
+### Added
+* `timetrace list records` command (#16)
+
+## [0.1.4] - 2021-05-14
+
+### Fixed
+* Fix calculation of total tracked time
+
+## [0.1.3] - 2021-05-14
+
+### Fixed
+* Fix determination of latest stored record
+
+## [0.1.2] - 2021-05-14
+
+### Fixed
+* Support slashes and back-slashes in project keys (#9)
+
+## [0.1.1] - 2021-05-14
+
+### Fixed
+* Fix status report for situations where time tracking is not active (#7)
+
+## [0.1.0] - 2021-05-13
+
+### The initial timetrace release.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3e19c798537
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=timetrace
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A simple time-tracking CLI tool"
+arch=('x86_64')
+url="https://github.com/dominikbraun/timetrace"
+license=('Apache')
+depends=('glibc')
+makedepends=('go')
+install="$pkgname.install"
+changelog=CHANGELOG.md
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('5655bcdc70926b07556d79d0edbdace3d04976c888460011b59c34a552f1ed0e')
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname-$pkgver"
+ go build -o "$pkgname"
+}
+
+check() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dvm 755 "$pkgname" -t "$pkgdir/usr/bin/"
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/timetrace.install b/timetrace.install
new file mode 100644
index 000000000000..1906b3adb99f
--- /dev/null
+++ b/timetrace.install
@@ -0,0 +1,3 @@
+post_install() {
+ printf ":: You can create a custom config under \$HOME/.timetrace/config.yaml\n"
+}