summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-10 10:04:09 -0500
committerLuis Martinez2021-08-10 10:04:09 -0500
commitcd64160ab5737a4826a1aa034e4840f5be4c0b19 (patch)
tree32f746759b21a6055f641022f5c7829b8aefd9cd
parent37e7d250f703814c3a327098ad536ea0326e701e (diff)
downloadaur-cd64160ab5737a4826a1aa034e4840f5be4c0b19.tar.gz
update to 0.13.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md13
-rw-r--r--PKGBUILD4
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 126b02478dee..1730fe6e1070 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = timetrace
pkgdesc = A simple time-tracking CLI tool
- pkgver = 0.12.0
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/dominikbraun/timetrace
install = timetrace.install
@@ -9,7 +9,7 @@ pkgbase = timetrace
license = Apache
makedepends = go
depends = glibc
- source = timetrace-0.12.0.tar.gz::https://github.com/dominikbraun/timetrace/archive/v0.12.0.tar.gz
- sha256sums = ebe325acc002914663399ac1bc7a438fb44b54f2ce3b8adbdc494a93a4323514
+ source = timetrace-0.13.0.tar.gz::https://github.com/dominikbraun/timetrace/archive/v0.13.0.tar.gz
+ sha256sums = 1edd3a51782242a60503476e9f9e10215f3b90992a35e9deec1d578ec41ead5d
pkgname = timetrace
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 1cfdea36ddb0..efa848cd90c0 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -5,6 +5,19 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+## [0.13.0] - 2021-08-10
+
+### Added
+* Add support for per-project configuration (#166)
+* Add support for making projects billable by default (#166)
+* Add support for deleting and reverting projects with their modules (#160)
+* Add support for restoring records associated with a restored project (#160)
+* Add `--non-billable` flag for `timetrace start` command (#172)
+* Add `--non-billable` flag for `timetrace report` command (#142)
+
+### Changed
+* Ask the user whether they want to delete all records when deleting a project (#160)
+
## [0.12.0] - 2021-07-30
### Changed
diff --git a/PKGBUILD b/PKGBUILD
index e21388ef8df4..9c8dd4a5c687 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=timetrace
-pkgver=0.12.0
+pkgver=0.13.0
pkgrel=1
pkgdesc="A simple time-tracking CLI tool"
arch=('x86_64')
@@ -12,7 +12,7 @@ makedepends=('go')
install="$pkgname.install"
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('ebe325acc002914663399ac1bc7a438fb44b54f2ce3b8adbdc494a93a4323514')
+sha256sums=('1edd3a51782242a60503476e9f9e10215f3b90992a35e9deec1d578ec41ead5d')
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"