summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Bradfield2021-06-04 13:33:26 +0100
committerRichard Bradfield2021-06-04 13:33:26 +0100
commit9225602e6b2ff56502bf9f39755a64be62ee0ada (patch)
tree98a9d5a66edd2dccb3453f1c268ae875b5b202fe
downloadaur-9225602e6b2ff56502bf9f39755a64be62ee0ada.tar.gz
Initial commit, packages v2021.1.1 AppImage
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
-rw-r--r--wrapper.sh3
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6af0b89bff0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = timing71
+ pkgdesc = Desktop client for the Timing71 live timing aggregation service.
+ pkgver = 2021.1.1
+ pkgrel = 1
+ url = https://www.timing71.org
+ arch = x86_64
+ license = custom
+ depends = electron9
+ source = timing71-v2021.1.1.AppImage::https://releases.timing71.org/client/v2021.1.1/Timing71%20Client%20v2021.1.1.AppImage
+ source = wrapper.sh
+ sha512sums = c088425bf903beb2df8dcef59cc1f2c9cfab6606c5bfc8630561258fa9a752eb634e5ccd08c34e904fa86dc6e6ce4184186e43d11715e148f194c1d42e49c800
+ sha512sums = cfa60e34c36c03af745c3989bd184f1275cbe962db53dc5aec0ed96c865cbfba98a92b4ebac4f0e17fdc2d0dcb6281d4db23c9ad1fe85514b7e21e3d652685b2
+
+pkgname = timing71
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..18ad44ea0e78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.AppImage
+*.pkg.*
+pkg/
+src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0db5b4e746c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Richard Bradfield <bradfier@fstab.me>
+# Developer: James Muscat <james@timing71.org>
+
+pkgname=timing71
+pkgver=2021.1.1
+pkgrel=1
+pkgdesc="Desktop client for the Timing71 live timing aggregation service."
+arch=('x86_64')
+url="https://www.timing71.org"
+license=('custom')
+depends=('electron9')
+# options=(!strip)
+source=("$pkgname-v$pkgver.AppImage::https://releases.timing71.org/client/v$pkgver/Timing71%20Client%20v$pkgver.AppImage"
+ "wrapper.sh")
+sha512sums=('c088425bf903beb2df8dcef59cc1f2c9cfab6606c5bfc8630561258fa9a752eb634e5ccd08c34e904fa86dc6e6ce4184186e43d11715e148f194c1d42e49c800'
+ 'cfa60e34c36c03af745c3989bd184f1275cbe962db53dc5aec0ed96c865cbfba98a92b4ebac4f0e17fdc2d0dcb6281d4db23c9ad1fe85514b7e21e3d652685b2')
+
+prepare() {
+ chmod +x "$pkgname-v$pkgver".AppImage
+ ./"$pkgname-v$pkgver".AppImage --appimage-extract
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib/"$pkgname"
+ cp -a squashfs-root/resources/ "$pkgdir"/usr/lib/"$pkgname"/
+ chmod 755 "$pkgdir"/usr/lib/"$pkgname"/resources
+
+ install -D "wrapper.sh" "$pkgdir"/usr/lib/"$pkgname/$pkgname"
+
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s "$pkgdir"/usr/lib/"$pkgname/$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+}
diff --git a/wrapper.sh b/wrapper.sh
new file mode 100644
index 000000000000..9a41bc8b46c7
--- /dev/null
+++ b/wrapper.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec electron9 /usr/lib/timing71/resources/app.asar "$@"