summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTanjiro Kamado2019-07-08 08:42:01 +0200
committerTanjiro Kamado2019-07-08 08:42:01 +0200
commit7552f80f68332a6cea34869de6524d3d55f489ba (patch)
tree7c40c7a723d88b1b5acb051e9f3e5ebb2febb1cc
downloadaur-7552f80f68332a6cea34869de6524d3d55f489ba.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--wx3.patch62
4 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a90a4a4b2ace
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = timingeditor
+ pkgdesc = The Timing Editor is a free tool to draw timing diagrams.
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://timingeditor.sourceforge.net
+ arch = x86_64
+ license = GPL2
+ depends = wxgtk
+ source = https://datapacket.dl.sourceforge.net/project/timingeditor/timingeditor/0.1/TimingEditor-0.1-src.7z
+ source = wx3.patch
+ sha256sums = 59c6f0c6c3c64394c187591d1eaefc97bdb440451935a16b2722ff91dea9952f
+ sha256sums = 95e4045e8bfa7422dc6eb7639d9c02b0961992b839cd7cd52d6a1f6e75a03b6b
+
+pkgname = timingeditor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..695bccf9ded5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+*.7z
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67d3b4c2e348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tanjiro Kamado <tanjiro.kamado at yandex dot com>
+pkgname=timingeditor
+_ccn=TimingEditor
+pkgver=0.1
+pkgrel=1
+pkgdesc="The Timing Editor is a free tool to draw timing diagrams. "
+arch=('x86_64')
+url="http://timingeditor.sourceforge.net"
+license=('GPL2')
+depends=('wxgtk')
+makedepends=()
+source=("https://datapacket.dl.sourceforge.net/project/timingeditor/timingeditor/$pkgver/$_ccn-$pkgver-src.7z"
+ "wx3.patch")
+sha256sums=(
+ '59c6f0c6c3c64394c187591d1eaefc97bdb440451935a16b2722ff91dea9952f'
+ '95e4045e8bfa7422dc6eb7639d9c02b0961992b839cd7cd52d6a1f6e75a03b6b'
+ )
+
+prepare() {
+ cd "$_ccn"
+ patch -p1 -i "$srcdir/wx3.patch"
+}
+
+build() {
+ cd "$_ccn"
+ g++ *.cpp -DNDEBUG `wx-config --cxxflags --libs std,aui` -o $_ccn
+}
+
+package() {
+ _base="$pkgdir/usr/bin"
+ cd "$_ccn"
+ mkdir -p "$_base/$_ccn"
+ cp "$_ccn" "$_base/$_ccn/"
+ rm -rf art/.svn
+ cp -r art "$_base/$_ccn/"
+ cd "$_base"
+ ln -s "$_ccn/$_ccn" "$pkgname"
+}
diff --git a/wx3.patch b/wx3.patch
new file mode 100644
index 000000000000..1616a4e2f990
--- /dev/null
+++ b/wx3.patch
@@ -0,0 +1,62 @@
+diff --git a/TimingApp.cpp b/TimingApp.cpp
+index e943d7d..7bbca43 100644
+--- a/TimingApp.cpp
++++ b/TimingApp.cpp
+@@ -63,7 +63,7 @@ bool TimingApp::OnInit()
+ { wxCMD_LINE_OPTION, _T("i"), _T("input"), _T("input dir") },
+ { wxCMD_LINE_OPTION, _T("s"), _T("size"), _T("output block size"), wxCMD_LINE_VAL_NUMBER },
+ { wxCMD_LINE_OPTION, _T("d"), _T("date"), _T("output file date"), wxCMD_LINE_VAL_DATE },*/
+- { wxCMD_LINE_PARAM, NULL, NULL, _T("input file"), wxCMD_LINE_VAL_STRING, wxCMD_LINE_PARAM_MULTIPLE|wxCMD_LINE_PARAM_OPTIONAL },
++ { wxCMD_LINE_PARAM, NULL, NULL, wxT_2("input file"), wxCMD_LINE_VAL_STRING, wxCMD_LINE_PARAM_MULTIPLE|wxCMD_LINE_PARAM_OPTIONAL },
+ { wxCMD_LINE_NONE }
+ };
+ parser.SetDesc(cmdLineDesc);
+@@ -188,7 +188,7 @@ wxMDIChildFrame *TimingApp::CreateChildFrame(wxDocument *doc, wxView *view)
+ #ifdef __WXMSW__
+ subframe->SetIcon(wxIcon(_T("wxwinicon")));
+ #else
+- subframe->SetIcon(wxIcon(_T("wxwinicon.xpm")));
++ //subframe->SetIcon(wxIcon(_T("wxwinicon.xpm")));^M
+ #endif
+
+ /// Make a menubar
+diff --git a/TimingView.cpp b/TimingView.cpp
+index 41c06cb..cafb8f0 100644
+--- a/TimingView.cpp
++++ b/TimingView.cpp
+@@ -36,7 +36,7 @@
+ #endif
+
+ #include <wx/clipbrd.h>
+-#include <wx/svg/dcsvg.h>
++#include <wx/dcsvg.h>
+ #include <wx/dcps.h>
+ #include <wx/filename.h>
+
+@@ -415,7 +415,7 @@ bool TimingView::CanDelete(void)
+ }
+ void TimingView::OnExportBitmap(wxCommandEvent& event)
+ {
+- wxFileDialog dlg( wxGetApp().GetMainFrame(), _T("Choose a file for exporting into it"),_T(""),_T(""),_T("PNG files (*.png)|*.png"),wxSAVE | wxOVERWRITE_PROMPT );
++ wxFileDialog dlg( wxGetApp().GetMainFrame(), _T("Choose a file for exporting into it"),_T(""),_T(""),_T("PNG files (*.png)|*.png"),wxFC_SAVE | wxFD_OVERWRITE_PROMPT );
+ if ( dlg.ShowModal() != wxID_OK )
+ return;
+
+@@ -451,7 +451,7 @@ void TimingView::OnExportBitmap(wxCommandEvent& event)
+
+ void TimingView::OnExportSVG(wxCommandEvent& event)
+ {
+- wxFileDialog dlg( wxGetApp().GetMainFrame(), _T("Choose a file for exporting into it"), _T(""), _T(""), _T("SVG files (*.svg)|*.svg"), wxSAVE | wxOVERWRITE_PROMPT);
++ wxFileDialog dlg( wxGetApp().GetMainFrame(), _T("Choose a file for exporting into it"), _T(""), _T(""), _T("SVG files (*.svg)|*.svg"), wxFC_SAVE | wxFD_OVERWRITE_PROMPT);
+ if ( dlg.ShowModal() != wxID_OK )
+ return;
+ wxString filename = dlg.GetPath();
+@@ -470,7 +470,7 @@ void TimingView::OnExportSVG(wxCommandEvent& event)
+
+ void TimingView::OnExportPS(wxCommandEvent& event)
+ {
+- wxFileDialog dlg( wxGetApp().GetMainFrame(), _T("Choose a file for exporting into it"), _T(""), _T(""), _T("PostScrip files (*.ps)|*.ps"), wxSAVE | wxOVERWRITE_PROMPT);
++ wxFileDialog dlg( wxGetApp().GetMainFrame(), _T("Choose a file for exporting into it"), _T(""), _T(""), _T("PostScrip files (*.ps)|*.ps"), wxFC_SAVE | wxFD_OVERWRITE_PROMPT);
+ if ( dlg.ShowModal() != wxID_OK )
+ return;
+ wxString filename = dlg.GetPath();