summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorender2019-07-11 22:28:51 +0200
committerender2019-07-11 22:28:51 +0200
commit0af4ec8b1ab2a1569bceed8385bf93e22c27315f (patch)
tree34221ae0a6b95cbc67062ae46b2ae1fb096311fa
downloadaur-0af4ec8b1ab2a1569bceed8385bf93e22c27315f.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD60
-rw-r--r--wx3.patch39
4 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9423e55aeb1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = timingeditor-svn
+ pkgdesc = The Timing Editor is a free tool to draw timing diagrams.
+ pkgver = r115
+ pkgrel = 1
+ url = http://timingeditor.sourceforge.net
+ arch = x86_64
+ license = GPL2
+ makedepends = subversion
+ depends = wxgtk
+ provides = timingeditor
+ conflicts = timingeditor
+ source = timingeditor-svn::svn+https://svn.code.sf.net/p/timingeditor/code/trunk
+ source = wx3.patch
+ sha256sums = SKIP
+ sha256sums = cc0e4f8b477e59185b4d5dd58fef3de4eb48ebdcdddd136aeffa8a28c326cfbb
+
+pkgname = timingeditor-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..695bccf9ded5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+*.7z
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f494b7d092e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Tanjiro Kamado <tanjiro.kamado at yandex dot com>
+pkgname=timingeditor-svn
+_pkgN=timingeditor
+_ccn=TimingEditor
+pkgver=r115
+pkgrel=1
+pkgdesc="The Timing Editor is a free tool to draw timing diagrams. "
+arch=('x86_64')
+url="http://timingeditor.sourceforge.net"
+license=('GPL2')
+groups=()
+depends=('wxgtk')
+makedepends=('subversion')
+provides=("timingeditor")
+conflicts=("timingeditor")
+replaces=()
+backup=()
+options=()
+install=
+source=(
+ 'timingeditor-svn::svn+https://svn.code.sf.net/p/timingeditor/code/trunk'
+ "wx3.patch"
+)
+noextract=()
+sha256sums=(
+ 'SKIP'
+ 'cc0e4f8b477e59185b4d5dd58fef3de4eb48ebdcdddd136aeffa8a28c326cfbb'
+ )
+
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s" "$(svnversion | tr -d 'A-z')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname}"
+ patch -p1 -i "$srcdir/wx3.patch"
+ #sed -i s/\#include \<wx/svg/dcsvg.h\>/\#include \<wx\/dcsvg.h\>/g TimingView.cpp
+ #sed -i s/wxCMD_LINE_PARAM, NULL, NULL, _T\(\"input file\"\)/wxCMD_LINE_PARAM, NULL, NULL, wxT_2\(\"input file\"\)/g TimingApp.cpp
+
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ g++ *.cpp -DNDEBUG `wx-config --cxxflags --libs std,aui` -o $_ccn
+}
+
+
+package() {
+ _base="$pkgdir/usr/bin"
+ cd "$srcdir/${pkgname}"
+
+ mkdir -p "$_base/$_ccn"
+ cp "$_ccn" "$_base/$_ccn/"
+ rm -rf art/.svn
+ cp -r art "$_base/$_ccn/"
+ cd "$_base"
+ ln -s "$_ccn/$_ccn" "$_pkgN"
+}
diff --git a/wx3.patch b/wx3.patch
new file mode 100644
index 000000000000..f665057e75ad
--- /dev/null
+++ b/wx3.patch
@@ -0,0 +1,39 @@
+diff --git a/TimingApp.cpp b/TimingApp.cpp
+index ed78990..e2b5509 100644
+--- a/TimingApp.cpp
++++ b/TimingApp.cpp
+@@ -63,7 +63,7 @@ bool TimingApp::OnInit()
+ { wxCMD_LINE_OPTION, _T("i"), _T("input"), _T("input dir") },
+ { wxCMD_LINE_OPTION, _T("s"), _T("size"), _T("output block size"), wxCMD_LINE_VAL_NUMBER },
+ { wxCMD_LINE_OPTION, _T("d"), _T("date"), _T("output file date"), wxCMD_LINE_VAL_DATE },*/
+- { wxCMD_LINE_PARAM, NULL, NULL, _T("input file"), wxCMD_LINE_VAL_STRING, wxCMD_LINE_PARAM_MULTIPLE|wxCMD_LINE_PARAM_OPTIONAL },
++ { wxCMD_LINE_PARAM, NULL, NULL,wxT_2("input file"), wxCMD_LINE_VAL_STRING, wxCMD_LINE_PARAM_MULTIPLE|wxCMD_LINE_PARAM_OPTIONAL },
+ { wxCMD_LINE_NONE }
+ };
+ parser.SetDesc(cmdLineDesc);
+diff --git a/TimingSubFrame.cpp b/TimingSubFrame.cpp
+index 016d529..c85ef6e 100644
+--- a/TimingSubFrame.cpp
++++ b/TimingSubFrame.cpp
+@@ -13,8 +13,6 @@ TimingSubFrame::TimingSubFrame(wxDocument *doc, wxView* view, wxMDIParentFrame *
+
+ #ifdef __WXMSW__
+ SetIcon(wxIcon(_T("wxwinicon")));
+- #else
+- SetIcon(wxIcon(_T("wxwinicon.xpm")));
+ #endif
+
+ /// Make a menubar
+diff --git a/TimingView.cpp b/TimingView.cpp
+index 7940225..dd4bad2 100644
+--- a/TimingView.cpp
++++ b/TimingView.cpp
+@@ -36,7 +36,7 @@
+ #endif
+
+ #include <wx/clipbrd.h>
+-#include <wx/svg/dcsvg.h>
++#include <wx/dcsvg.h>
+ #include <wx/dcps.h>
+ #include <wx/filename.h>
+