summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnmanuel2023-10-02 23:27:45 +0000
committerEnmanuel2023-10-02 23:27:45 +0000
commit9e1b82f239529331c1834e33abd7d2aca0d45533 (patch)
treed08a7664cd7854c510850be2592d6fa72f09c349
downloadaur-9e1b82f239529331c1834e33abd7d2aca0d45533.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef1332353205
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = timoni-bin
+ pkgdesc = Timoni is a package manager for Kubernetes, powered by CUE and inspired by Helm.
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://github.com/stefanprodan/timoni
+ arch = x86_64
+ license = Apache 2
+ provides = timoni-bin
+ conflicts = timoni
+ source = timoni-0.14.0.tar.gz::https://github.com/stefanprodan/timoni/releases/download/v0.14.0/timoni_0.14.0_linux_amd64.tar.gz
+ sha256sums = 4fea2108a2846956a51752a59af3bd227846c0cd00ba5ac18822fffa1601ae12
+
+pkgname = timoni-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b7b7c57e023
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Enmanuel Moreira <enmanuelmoreira@gmail.com>
+
+pkgname=timoni-bin
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="Timoni is a package manager for Kubernetes, powered by CUE and inspired by Helm."
+arch=('x86_64')
+url="https://github.com/stefanprodan/timoni"
+conflicts=('timoni')
+provides=('timoni-bin')
+license=('Apache 2')
+
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('4fea2108a2846956a51752a59af3bd227846c0cd00ba5ac18822fffa1601ae12')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 "timoni" "${pkgdir}/usr/bin/timoni"
+ install -D -m 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}