summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 16:04:05 +0200
committeraksr2015-06-28 16:04:05 +0200
commit21cac58397152e742519b4cd9dd828606ace9d56 (patch)
tree3f7f491db13a6a7713bac7e274c7207d5a6c8e21
downloadaur-21cac58397152e742519b4cd9dd828606ace9d56.tar.gz
Start.
-rw-r--r--.SRCINFO27
-rw-r--r--LICENSE35
-rw-r--r--PKGBUILD68
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..784d3cb8b2d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = tin
+ pkgdesc = A threaded NNTP and spool based UseNet newsreader.
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://www.tin.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = ncurses
+ depends = ispell
+ depends = perl
+ depends = gnupg
+ depends = dante
+ depends = icu
+ depends = libidn
+ conflicts = tin-unstable
+ source = ftp://ftp.tin.org/pub/news/clients/tin/stable/tin-2.2.1.tar.gz
+ source = LICENSE
+ md5sums = 31ca384c33b5d7b58065cfa0a5b23a35
+ md5sums = 22de35b1bdc6f0df87c93ae794198b21
+ sha1sums = 9ef12345ed1cfb482138c5c54a7f73dfb91b9039
+ sha1sums = 07e1217ee68bb20f0ad2670e84116a0d67243063
+ sha256sums = cf588884bbe4711498b807311e53d82a1b6ca343f4c85e53001c90e8c0e456ac
+ sha256sums = 5ccb431a94c2d2f093b8f93325075e5ad886772ba2a452478120b86ce71c0683
+
+pkgname = tin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b39f06bc1cc0
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,35 @@
+/*
+ * Project : tin - a Usenet reader
+ * Module : main.c
+ * Author : I. Lea & R. Skrenta
+ * Created : 1991-04-01
+ * Updated : 2005-08-14
+ * Notes :
+ *
+ * Copyright (c) 1991-2006 Iain Lea <iain@bricbrac.de>, Rich Skrenta <skrenta@pbm.com>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. The name of the author may not be used to endorse or promote
+ * products derived from this software without specific prior written
+ * permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS
+ * OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+ * DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
+ * GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+ * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+ * NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da24b21620a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: akojo
+# Contributor: quizzlo
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=tin
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="A threaded NNTP and spool based UseNet newsreader."
+arch=('i686' 'x86_64')
+url="http://www.tin.org"
+license=('BSD')
+depends=('ncurses' 'ispell' 'perl' 'gnupg' 'dante' 'icu' 'libidn')
+conflicts=('tin-unstable')
+source=("ftp://ftp.tin.org/pub/news/clients/tin/stable/$pkgname-$pkgver.tar.gz"
+ 'LICENSE')
+md5sums=('31ca384c33b5d7b58065cfa0a5b23a35'
+ '22de35b1bdc6f0df87c93ae794198b21')
+sha1sums=('9ef12345ed1cfb482138c5c54a7f73dfb91b9039'
+ '07e1217ee68bb20f0ad2670e84116a0d67243063')
+sha256sums=('cf588884bbe4711498b807311e53d82a1b6ca343f4c85e53001c90e8c0e456ac'
+ '5ccb431a94c2d2f093b8f93325075e5ad886772ba2a452478120b86ce71c0683')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ unset CFLAGS
+ unset CPPFLAGS
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --enable-shell-escape \
+ --enable-nntp \
+ --enable-nls \
+ --enable-ipv6 \
+ --enable-append-pid \
+ --enable-posting \
+ --enable-piping \
+ --enable-locale \
+ --enable-xhdr-xref \
+ --with-spool-dir=/var/spool/news \
+ --with-ispell=/usr/bin/ispell \
+ --with-gpg=/usr/bin/gpg \
+ --with-pcre=/usr \
+ --with-screen=ncursesw \
+ --with-inews-dir=/usr/lib/news \
+ --with-libdir=/usr/lib/news \
+ --with-coffee \
+ --with-socks \
+ --with-socks5 \
+ --disable-prototypes \
+ --disable-echo
+# --with-domain-name (default: unset)
+# --with-nntp-default-server (default: news.$DOMAIN_NAME)
+# --with-shell=PROG (default: sh, except on BSD where csh is used)
+# --with-defaults-dir=PATH (default: /etc/tin)
+# --with-editor=PROG (default: empty)
+# --with-mailer=PROG (default: empty)
+# --with-mailbox=PATH (default: empty)
+ make build
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+ rm -f $pkgdir/usr/share/man/man5/mbox.5
+ rm -f $pkgdir/usr/share/man/man5/mmdf.5
+ mv $pkgdir/usr/bin/url_handler.pl $pkgdir/usr/bin/tin_url_handler.pl
+ install -D -m644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+