summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOskari Rauta2016-09-07 23:34:45 +0300
committerOskari Rauta2016-09-07 23:34:45 +0300
commit9b2ca9123da1d7d0b03a60d993c2e135b54400a8 (patch)
tree6d097c10b80e676affd28f154d0f6703c9821ea8
downloadaur-9b2ca9123da1d7d0b03a60d993c2e135b54400a8.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--tint2-improved.install11
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afe3008e88d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = tint2-improved
+ pkgdesc = Tint2 with support for gradient backgrounds and separator plugins
+ pkgver = 0.12.12
+ pkgrel = 1
+ url = https://gitlab.com/oskarirauta/tint2
+ install = tint2-improved.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = gtk2
+ depends = imlib2
+ depends = startup-notification
+ provides = tint2
+ conflicts = tint2
+ conflicts = tint
+ conflicts = tint2-svn
+ conflicts = tint2-git
+ source = git+https://gitlab.com/oskarirauta/tint2.git
+ md5sums = SKIP
+
+pkgname = tint2-improved
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e88980bc9cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Oskari Rauta <oskari.rauta@gmail.com>
+
+pkgname=tint2-improved
+_pkgname=tint2
+pkgrel=1
+pkgver=0.12.12
+pkgdesc="Tint2 with support for gradient backgrounds and separator plugins"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/oskarirauta/tint2"
+license=('GPL')
+depends=('gtk2' 'imlib2' 'startup-notification')
+makedepends=('cmake')
+install=${pkgname}.install
+provides=('tint2')
+conflicts=('tint2' 'tint' 'tint2-svn' 'tint2-git')
+source=("git+https://gitlab.com/oskarirauta/tint2.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+
+build() {
+ cd "$srcdir/$_pkgname"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/tint2-improved.install b/tint2-improved.install
new file mode 100644
index 000000000000..a2930a4ff27b
--- /dev/null
+++ b/tint2-improved.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}