summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLartza2017-06-10 10:12:52 +0300
committerLartza2017-06-10 10:12:52 +0300
commit17175157d9d6fe510768cb24a4493c8e2da9991a (patch)
tree090b3fcbdf4a85b5937d84a69f709fa8cd206d9d
parent704d106bfa01e97144568a54e863dd40a4028e80 (diff)
downloadaur-17175157d9d6fe510768cb24a4493c8e2da9991a.tar.gz
Update deps, pkgver
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0c04569e870..eb804cac0b4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Jun 10 07:11:33 UTC 2017
pkgbase = tint3-cpp-git
pkgdesc = A C++ rewrite attempt of the tint2 panel.
- pkgver = r691.9c13801
+ pkgver = 0.3.0.r43.gfc908ec
pkgrel = 1
url = https://github.com/jmc-88/tint3
arch = i686
@@ -9,12 +11,15 @@ pkgbase = tint3-cpp-git
license = GPL2
makedepends = git
makedepends = cmake
+ makedepends = pandoc
+ makedepends = xorg-server-xvfb
depends = imlib2
depends = pango
depends = libxinerama
depends = libxrandr
depends = libxcomposite
depends = startup-notification
+ depends = hicolor-icon-theme
source = tint3::git+https://github.com/jmc-88/tint3.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5527b943baf0..86c64a40460f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
# Maintainer: Lari Tikkanen <lartza@wippies.com>
pkgname=tint3-cpp-git
-pkgver=r691.9c13801
+pkgver=0.3.0.r43.gfc908ec
pkgrel=1
pkgdesc="A C++ rewrite attempt of the tint2 panel."
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/jmc-88/tint3"
license=('GPL2')
-depends=('imlib2' 'pango' 'libxinerama' 'libxrandr' 'libxcomposite' 'startup-notification')
-makedepends=('git' 'cmake')
+depends=('imlib2' 'pango' 'libxinerama' 'libxrandr' 'libxcomposite' 'startup-notification' 'hicolor-icon-theme')
+makedepends=('git' 'cmake' 'pandoc' 'xorg-server-xvfb')
source=('tint3::git+https://github.com/jmc-88/tint3.git')
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/tint3"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {