summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2019-04-11 13:41:00 -0400
committerStorm Dragon2019-04-11 13:41:00 -0400
commit8c56c08216df56a5dc4de7c4557462e4882fa72a (patch)
tree10f8acb702bb654fd5518000912eecc092eee04b
downloadaur-8c56c08216df56a5dc4de7c4557462e4882fa72a.tar.gz
Initial commit.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD35
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2f66e049931
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Thu Apr 11 17:40:51 UTC 2019
+pkgbase = tintin-beta
+ pkgdesc = A console-based MUD client beta version
+ pkgver = 2019.04.11
+ pkgrel = 1
+ url = http://tintin.sourceforge.net/
+ arch = aarch64
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = zlib
+ depends = pcre
+ depends = gnutls
+ provides = tt++
+ provides = tintin
+ conflicts = tt++
+ conflicts = tintin
+ replaces = tt++
+ replaces = tintin
+ options = strip
+ source = http://tintin.sourceforge.net/download/tintin-beta.tar.gz
+ md5sums = SKIP
+
+pkgname = tintin-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5d1e4763fc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+
+_pkgname="tintin"
+pkgname="tintin-beta"
+pkgver=2019.04.11
+pkgrel=1
+pkgdesc="A console-based MUD client beta version"
+arch=('aarch64' 'armv7h' 'i686' 'x86_64')
+url="http://tintin.sourceforge.net/"
+license=('GPL2')
+depends=('zlib' 'pcre' 'gnutls')
+options=('strip')
+source=('http://tintin.sourceforge.net/download/tintin-beta.tar.gz')
+conflicts=("tt++" "tintin")
+provides=("tt++" "tintin")
+replaces=("tt++" "tintin")
+md5sums=('SKIP')
+
+pkgver() {
+ # Because there is no version number, the date will be used in yymmdd format.
+ date '+%Y.%m.%d'
+}
+
+build() {
+ cd $srcdir/tt/src
+ sh configure --prefix=/usr --enable-big5
+ make
+
+}
+
+package() {
+ cd $srcdir/tt/src
+ install -m755 -D tt++ $pkgdir/usr/bin/tt++
+ ln -sf tt++ $pkgdir/usr/bin/tintin
+}