summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Econopouly2020-11-19 15:40:58 -0500
committerNick Econopouly2020-11-19 15:40:58 -0500
commita28302375caf23069998f55ba861b5806c69fe1e (patch)
tree432af37ccc1dfa65f4f8bf501f6c991ec3a4657f
parent694afc8587ed4043ddf9af2b92a6624db36fb8cf (diff)
downloadaur-a28302375caf23069998f55ba861b5806c69fe1e.tar.gz
Add -p flag to mkdir command
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce65e8092f15..e43c6664569c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,23 +13,23 @@ source=(git+$url)
sha512sums=(SKIP)
build() {
- # Installs the Rust nightly toolchain to a temporary
- # directory. If you already have the toolchain installed,
- # e.g. via the script at https://rustup.rs/ or another
- # package, you can remove the rust-nightly dependancy and
- # comment out the following three commands.
-
- mkdir nightly
- export RUSTUP_HOME=$(pwd)/nightly
- rustup toolchain install nightly
+ # Installs the Rust nightly toolchain to a temporary
+ # directory. If you already have the toolchain installed,
+ # e.g. via the script at https://rustup.rs/ or another
+ # package, you can remove the rust-nightly dependancy and
+ # comment out the following three commands.
- # build tiny
- cd tiny
- cargo +nightly build --release
+ mkdir -p nightly
+ export RUSTUP_HOME=$(pwd)/nightly
+ rustup toolchain install nightly
+
+ # build tiny
+ cd tiny
+ cargo +nightly build --release
}
package() {
- cd tiny
- install -Dm755 target/release/tiny "$pkgdir/usr/bin/tiny"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/tiny/LICENSE"
+ cd tiny
+ install -Dm755 target/release/tiny "$pkgdir/usr/bin/tiny"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/tiny/LICENSE"
}