summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreoli3n2021-11-08 10:52:01 +0100
committereoli3n2021-11-08 10:52:01 +0100
commita551e8ee4ee3c9203c3541d6a19d08fa4156fc5b (patch)
treec640766128c2fceba3ed85b2a57493fb683a508b
parent6e92af7cea723e9f0b5b7f379fb132f694b7e670 (diff)
downloadaur-a551e8ee4ee3c9203c3541d6a19d08fa4156fc5b.tar.gz
update to v0.10.0.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 4 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4092e1ba4081..d85cbadf0d44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = tiny-irc-client-git
pkgdesc = A console IRC client
- pkgver = 0.8.0
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/osa1/tiny
arch = x86_64
license = MIT
makedepends = git
+ makedepends = rust-nightly
depends = openssl
depends = dbus
provides = tiny-irc-client
@@ -14,4 +15,3 @@ pkgbase = tiny-irc-client-git
sha512sums = SKIP
pkgname = tiny-irc-client-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 285c2e189100..6c1981bc0e6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nick Econopouly <wry at mm dot st>
pkgname=tiny-irc-client-git
-pkgver="0.8.0"
+pkgver="0.10.0"
pkgrel=1
pkgdesc="A console IRC client"
arch=('x86_64')
@@ -9,22 +9,12 @@ conflicts=('tiny-irc-client')
url="https://github.com/osa1/tiny"
license=('MIT')
depends=('openssl' 'dbus')
-makedepends=('git' 'rust-nightly')
+makedepends=('git' 'rust')
source=(git+$url)
sha512sums=(SKIP)
build() {
- # Installs the Rust toolchain to a temporary directory. If you
- # already have the toolchain installed, e.g. via the script at
- # https://rustup.rs/ or another package, you can remove the
- # rust-nightly dependancy and comment out the following three
- # commands.
-
- mkdir -p stable
- export RUSTUP_HOME=$(pwd)/stable
- rustup toolchain install stable
-
# build tiny
cd tiny
cargo install --path crates/tiny --features=desktop-notifications