summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Torres2023-12-04 12:38:25 +0000
committerRalph Torres2023-12-04 12:38:25 +0000
commit1686cd699a5112c45501ca8528fa33bf9b4bfb34 (patch)
tree3a7a69a4a0672d1f14a0afe3aec3acbc3d05535a
parent4dac4051e49e4dd47cc9180d3bbed1c8b68173bd (diff)
downloadaur-1686cd699a5112c45501ca8528fa33bf9b4bfb34.tar.gz
update conflicts, deps, source
conflicts: add the package in provides, conflicts dependencies: change libdbus to dbus remove openssl: we build the variant that depends on rustls source: rename tarball to $pkgname-$pkgver change sig type to sha256
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba61a082642a..26138f2aa6cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,10 @@ pkgbase = tiny-irc-client
arch = x86_64
license = MIT
makedepends = cargo
- depends = libdbus
- depends = openssl
- source = https://github.com/osa1/tiny/archive/v0.10.0.tar.gz
- md5sums = cf95b03493548e629cadb3b8ae74a764
+ depends = dbus
+ provides = tiny-irc-client
+ conflicts = tiny-irc-client
+ source = tiny-0.10.0.tar.gz::https://github.com/osa1/tiny/archive/v0.10.0.tar.gz
+ sha256sums = 7f4751b5e34057ba65e86f3819f2ae8288307a5a8e83e5fbb2733759c8100cb7
pkgname = tiny-irc-client
diff --git a/PKGBUILD b/PKGBUILD
index de0aa723a315..6837a50c8afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Contributor: ny-a <nyaarch64 at gmail dot com>
# Contributor: Jean Lucas <jean at 4ray dot co>
+_pkgname=tiny
pkgname=tiny-irc-client
pkgver=0.10.0
pkgrel=2
@@ -10,10 +11,12 @@ arch=(x86_64)
url=https://github.com/osa1/tiny
license=(MIT)
-depends=(libdbus openssl)
+provides=($pkgname)
+conflicts=($pkgname)
+depends=(dbus)
makedepends=(cargo)
-source=(https://github.com/osa1/tiny/archive/v${pkgver}.tar.gz)
-md5sums=(cf95b03493548e629cadb3b8ae74a764)
+source=($_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha256sums=(7f4751b5e34057ba65e86f3819f2ae8288307a5a8e83e5fbb2733759c8100cb7)
build() {
cd "$srcdir"/tiny-$pkgver