summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-11-23 23:39:53 -0500
committerJean Lucas2019-11-23 23:39:53 -0500
commita84b9d489237f87ccdcc5d4fbfe29a444a8aedd5 (patch)
tree6d49b330b24c42f9d803b732b1a72c990c80e7cb
parent008beffa067d586729e4c0370ba8b62b39e63038 (diff)
downloadaur-a84b9d489237f87ccdcc5d4fbfe29a444a8aedd5.tar.gz
Switch to Git and commit-based build for now since crate dependencies are moving targets
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d241d9b318fb..bbb32639535e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = tiny-irc-client
pkgdesc = Console IRC client written in Rust
- pkgver = 0.4.5
+ pkgver = 0.5.0+r31+gfe2659b
pkgrel = 1
url = https://github.com/osa1/tiny
arch = i686
arch = x86_64
+ arch = aarch64
license = MIT
+ makedepends = git
makedepends = rustup
depends = libdbus
- source = tiny-0.4.5.tar.gz::https://github.com/osa1/tiny/archive/35752a3526db3289d721e38c8b778ee9d55e185a.tar.gz
- sha512sums = f4d0d5c3708797dadc5b83ef773004d8a22a0fbb542c92ace88411856e262635bedf298b6f7a92091c7b8c05fde2f635ebe82424488d8ed100d9abc45afb73d0
+ source = git+https://github.com/osa1/tiny#commit=fe2659b9f93b7d179181c9b4c3aaa7342ad853c4
+ sha512sums = SKIP
pkgname = tiny-irc-client
diff --git a/PKGBUILD b/PKGBUILD
index 38960c385287..b4fbc1740404 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,36 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=tiny-irc-client
-pkgver=0.4.5
-_commit=35752a3526db3289d721e38c8b778ee9d55e185a
+pkgver=0.5.0+r31+gfe2659b
+_commit=fe2659b9f93b7d179181c9b4c3aaa7342ad853c4 # Tokio is a moving target, use a commit that builds with currently available libraries
pkgrel=1
pkgdesc='Console IRC client written in Rust'
-arch=(i686 x86_64)
+arch=(i686 x86_64 aarch64)
url=https://github.com/osa1/tiny
license=(MIT)
depends=(libdbus)
-makedepends=(rustup)
-source=(tiny-$pkgver.tar.gz::$url/archive/$_commit.tar.gz)
-sha512sums=('f4d0d5c3708797dadc5b83ef773004d8a22a0fbb542c92ace88411856e262635bedf298b6f7a92091c7b8c05fde2f635ebe82424488d8ed100d9abc45afb73d0')
+makedepends=(git rustup)
+source=(git+$url#commit=$_commit)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd tiny
+ git describe --tags | sed 's#-#+#g;s#+#+r#'
+}
build() {
- cd tiny-$_commit
+ cd tiny
rustup override set nightly
- cargo build --release
+ cargo build --release --locked
}
check() {
- cd tiny-$_commit
- cargo test --release
+ cd tiny
+ cargo test --release --locked
}
package() {
- cd tiny-$_commit
+ cd tiny
install -D target/release/tiny -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/tiny
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/tiny