summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-23 21:19:41 -0400
committerJean Lucas2019-06-23 21:19:41 -0400
commitb0a823dca861548356be919d5093dcdc368a1f33 (patch)
tree009e498ed51ea2ab56d3553fc9f195149de0d783
parent273c4a2f23d6df59f18a0f3c171402a7717db6c3 (diff)
downloadaur-b0a823dca861548356be919d5093dcdc368a1f33.tar.gz
Version bump, remove package variant conflicts
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60c7b16e3fdf..d41194a8efbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun May 12 03:12:00 UTC 2019
pkgbase = tiny-irc-client
pkgdesc = Console IRC client written in Rust
- pkgver = 0.4.4+522+g5bebf81
+ pkgver = 0.4.4+526+g35752a3
pkgrel = 1
url = https://github.com/osa1/tiny
arch = i686
@@ -12,8 +10,7 @@ pkgbase = tiny-irc-client
makedepends = rust-nightly
depends = openssl
depends = dbus
- conflicts = tiny-irc-client-git
- source = git+https://github.com/osa1/tiny#commit=5bebf810fc237df8db7a1d988398399b2e1513c7
+ source = git+https://github.com/osa1/tiny#commit=35752a3526db3289d721e38c8b778ee9d55e185a
sha512sums = SKIP
pkgname = tiny-irc-client
diff --git a/PKGBUILD b/PKGBUILD
index b9ebe8b8acb3..1c515054e380 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=tiny-irc-client
-pkgver=0.4.4+522+g5bebf81
+pkgver=0.4.4+526+g35752a3
+_commit=35752a3526db3289d721e38c8b778ee9d55e185a
pkgrel=1
pkgdesc='Console IRC client written in Rust'
arch=(i686 x86_64)
@@ -9,13 +10,12 @@ url=https://github.com/osa1/tiny
license=(MIT)
depends=(openssl dbus)
makedepends=(git rust-nightly)
-conflicts=(tiny-irc-client-git)
-source=(git+$url#commit=5bebf810fc237df8db7a1d988398399b2e1513c7)
+source=(git+$url#commit=$_commit)
sha512sums=(SKIP)
pkgver() {
cd tiny
- echo "$(grep '^version =' Cargo.toml | head -n1 | cut -d\" -f2)+$(git rev-list --count HEAD)+g$(git describe --always)"
+ printf %s+%s+%s $(grep '^version =' Cargo.toml | head -n1 | cut -d\" -f2) $(git rev-list --count HEAD) g$(git describe --always)
}
build() {