summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Econopouly2018-04-10 22:58:24 -0400
committerNick Econopouly2018-04-10 22:58:24 -0400
commit457a77d934b668da4f6cc3f19b18fd1c2eb45218 (patch)
tree1db0fb962046708ef6bceb0bb6315cb0ed4e08d5
downloadaur-457a77d934b668da4f6cc3f19b18fd1c2eb45218.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81a1dd98c7ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tiny-irc-client-git
+ pkgdesc = A console IRC client
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/osa1/tiny
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = rust-nightly
+ depends = openssl
+ depends = dbus
+ provides = tiny
+
+pkgname = tiny-irc-client-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b92e032ac77e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Nick Econopouly <wry at mm dot st>
+pkgname=tiny-irc-client-git
+pkgver="0.4.0"
+pkgrel=1
+pkgdesc="A console IRC client"
+arch=('x86_64')
+provides=('tiny')
+url="https://github.com/osa1/tiny"
+license=('MIT')
+depends=('openssl' 'dbus')
+makedepends=('git' 'rust-nightly')
+
+build() {
+ return 0
+}
+
+package() {
+ git clone "$url.git"
+ cd tiny
+ cargo +nightly build --release
+ install -Dm755 target/release/tiny "$pkgdir/usr/bin/tiny"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/tiny/LICENSE"
+
+} \ No newline at end of file