summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-26 15:14:09 +0800
committerzxp198210052024-01-26 15:14:09 +0800
commit4ff22c6ef3cc8e374c32c091c987f004f2544d1f (patch)
tree50514b520339285d776afed9fbb852415ae6535c
downloadaur-4ff22c6ef3cc8e374c32c091c987f004f2544d1f.tar.gz
update to 1.1.8
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD58
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0518e543b91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = tiny-rdm
+ pkgdesc = A modern lightweight cross-platform Redis desktop manager
+ pkgver = 1.1.8
+ pkgrel = 1
+ url = https://redis.tinycraft.cc/
+ arch = any
+ license = GPL-3.0-only
+ makedepends = nvm
+ makedepends = npm
+ makedepends = git
+ makedepends = go
+ makedepends = wails
+ makedepends = gcc
+ depends = gtk3
+ depends = webkit2gtk
+ conflicts = tiny-rdm
+ options = !strip
+ source = tiny-rdm.git::git+https://github.com/tiny-craft/tiny-rdm.git#tag=v1.1.8
+ source = tiny-rdm.sh
+ sha256sums = SKIP
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+
+pkgname = tiny-rdm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5876ce8d11b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=tiny-rdm
+_pkgname="Tiny RDM"
+pkgver=1.1.8
+_nodeversion=18
+pkgrel=1
+pkgdesc="A modern lightweight cross-platform Redis desktop manager"
+arch=('any')
+url="https://redis.tinycraft.cc/"
+_ghurl="https://github.com/tiny-craft/tiny-rdm"
+license=('GPL-3.0-only')
+conflicts=("${pkgname}")
+depends=(
+ 'gtk3'
+ 'webkit2gtk'
+)
+makedepends=(
+ 'nvm'
+ 'npm'
+ 'git'
+ 'go'
+ 'wails'
+ 'gcc'
+)
+options=(
+ '!strip'
+)
+source=(
+ "${pkgname}.git::git+${_ghurl}.git#tag=v${pkgver}"
+ "${pkgname}.sh"
+)
+sha256sums=('SKIP'
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+_ensure_local_nvm() {
+ export NVM_DIR="${srcdir}/.nvm"
+ source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
+ nvm install "${_nodeversion}"
+ nvm use "${_nodeversion}"
+}
+build() {
+ _ensure_local_nvm
+ cd "${srcdir}/${pkgname}.git"
+ npm install --prefix ./frontend
+ export CGO_ENABLED=1
+ export GOCACHE="${srcdir}/go-build"
+ export GOMODCACHE="${srcdir}/go/pkg/mod"
+ wails build -o "${pkgname}"
+ sed -e "s|{{.Info.ProductName}}|${_pkgname}|g" \
+ -e "s|/usr/local/bin/${pkgname}|${pkgname}|g" \
+ -e "s|{{.Info.Comments}}|${pkgdesc}|g" \
+ -i "build/linux/${pkgname}_0.0.0_amd64/usr/share/applications/${pkgname}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname}.git/build/bin/${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/${pkgname}.git/build/linux/${pkgname}_0.0.0_amd64/usr/share/applications/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${pkgname}.git/build/appicon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}.git/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file