summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Sommer2020-06-06 17:56:06 -0400
committerEthan Sommer2020-06-06 17:56:06 -0400
commit3978917643324b7070bb10870782aef63bf7c2d6 (patch)
tree677cab8e0899629f3e04443c8908b973fd10eaa1
downloadaur-3978917643324b7070bb10870782aef63bf7c2d6.tar.gz
add tinyalsa
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc41822616fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tinyalsa-git
+ pkgdesc = a small library to interface with ALSA in the Linux kernel
+ pkgver = 0.0
+ pkgrel = 1
+ url = https://github.com/tinyalsa/tinyalsa
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ depends = glibc
+ provides = tinyalsa
+ conflicts = tinyalsa
+ source = git+https://github.com/tinyalsa/tinyalsa.git
+ sha256sums = SKIP
+
+pkgname = tinyalsa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fd14e757fb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: E5ten <e5ten.arch@gmail.com>
+
+_pkgname='tinyalsa'
+pkgname="${_pkgname}-git"
+pkgver=0.0
+pkgrel=1
+pkgdesc='a small library to interface with ALSA in the Linux kernel'
+arch=('x86_64')
+url="https://github.com/${_pkgname}/${_pkgname}"
+license=('custom')
+depends=('glibc')
+makedepends=('cmake' 'git')
+provides=('tinyalsa')
+conflicts=('tinyalsa')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ cmake -S "${srcdir}/${_pkgname}" -B "${srcdir}/build" \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DTINYALSA_USES_PLUGINS='ON'
+ cmake --build "${srcdir}/build"
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install "${srcdir}/build"
+ install -Dm644 "${srcdir}/${_pkgname}/NOTICE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/NOTICE"
+}