summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Brandhorst2019-07-31 20:53:02 +0100
committerJohan Brandhorst2019-07-31 20:53:02 +0100
commita8df9b65ad8a4414bc4878f9ce115d20885c0e35 (patch)
treea3d92ee572616257fea56e5cc6a443b7ca4e45c4
downloadaur-a8df9b65ad8a4414bc4878f9ce115d20885c0e35.tar.gz
Add initial TinyGo release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46c0e1222c26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tinygo-bin
+ pkgdesc = TinyGo - Go for small spaces
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://tinygo.org
+ arch = x86_64
+ license = custom: BSD 3-clause
+ depends = gcc-libs
+ provides = tinygo
+ conflicts = tinygo
+ source = https://github.com/tinygo-org/tinygo/releases/download/v0.7.1/tinygo0.7.1.linux-amd64.tar.gz
+ source = https://raw.githubusercontent.com/tinygo-org/tinygo/v0.7.1/LICENSE
+ sha256sums = 2cc120bc84c79c8a861d405a6fc8cb87b9025e249d76044bdb76c986fed998d0
+ sha256sums = 5a12ca662a49786a0f16f0ffacb6afa30bdc0e953441dbe53e742385d7dcb239
+
+pkgname = tinygo-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d93f0f7e8569
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johan Brandhorst <johan.brandhorst at gmail dot com>
+pkgname=tinygo-bin
+pkgver=0.7.1
+pkgrel=1
+epoch=
+pkgdesc='TinyGo - Go for small spaces'
+arch=('x86_64')
+url='https://tinygo.org'
+license=('custom: BSD 3-clause')
+depends=('gcc-libs')
+provides=('tinygo')
+conflicts=('tinygo')
+source=("https://github.com/tinygo-org/tinygo/releases/download/v${pkgver}/tinygo${pkgver}.linux-amd64.tar.gz"
+ "https://raw.githubusercontent.com/tinygo-org/tinygo/v${pkgver}/LICENSE"
+)
+sha256sums=('2cc120bc84c79c8a861d405a6fc8cb87b9025e249d76044bdb76c986fed998d0'
+ '5a12ca662a49786a0f16f0ffacb6afa30bdc0e953441dbe53e742385d7dcb239'
+)
+
+package() {
+ install -d "${pkgdir}/usr/lib" "${pkgdir}/usr/bin"
+ cp -r tinygo "${pkgdir}/usr/lib/"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+
+ ln -sf /usr/lib/tinygo/bin/tinygo "${pkgdir}/usr/bin/tinygo"
+}