summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2020-10-31 16:56:55 +0100
committerDavide Depau2020-10-31 16:56:55 +0100
commit2607d97702bf0a544ce42813fee50785edd93204 (patch)
treecf56832d3e7436a03ef6e0dea41c4f9d47ac5ec7
parent762236be62004207c2e0a6dc8965ad2d2db73af8 (diff)
downloadaur-2607d97702bf0a544ce42813fee50785edd93204.tar.gz
Place submodules in source array
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4874e0aebb55..4a8a193e7108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tinygo-git
pkgdesc = Go compiler for small places. Microcontrollers, WebAssembly, and command-line tools. Based on LLVM.
pkgver = v0.15.0.r0.ge8615d10
- pkgrel = 2
+ pkgrel = 3
url = https://tinygo.org/
arch = i686
arch = pentium4
@@ -25,9 +25,23 @@ pkgbase = tinygo-git
provides = tinygo
conflicts = tinygo
source = tinygo::git+https://github.com/tinygo-org/tinygo.git
+ source = git+https://github.com/NordicSemiconductor/nrfx
+ source = git+https://github.com/ARM-software/CMSIS
+ source = git+https://github.com/avr-rust/avr-mcu
+ source = git+https://github.com/tinygo-org/cmsis-svd
+ source = git+https://github.com/llvm-mirror/compiler-rt#branch=release_80
+ source = git+https://github.com/CraneStation/wasi-libc
+ source = git+https://github.com/keith-packard/picolibc
source = LICENSE.llvm::https://llvm.org/LICENSE.txt
source = LICENSE.golang::https://raw.githubusercontent.com/golang/go/master/LICENSE
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = f72b120d1385408e9e380acc020756eb6ba1b461d66c328ea67327ba08d7dcfd
sha256sums = 2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067
diff --git a/PKGBUILD b/PKGBUILD
index c7422f950079..5fd45ef619b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=tinygo
pkgname=${_pkgname}-git
pkgver=v0.15.0.r0.ge8615d10
-pkgrel=2
+pkgrel=3
pkgdesc="Go compiler for small places. Microcontrollers, WebAssembly, and command-line tools. Based on LLVM."
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://tinygo.org/"
@@ -28,10 +28,24 @@ provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=(
"${_pkgname}::git+https://github.com/tinygo-org/tinygo.git"
+ "git+https://github.com/NordicSemiconductor/nrfx"
+ "git+https://github.com/ARM-software/CMSIS"
+ "git+https://github.com/avr-rust/avr-mcu"
+ "git+https://github.com/tinygo-org/cmsis-svd"
+ "git+https://github.com/llvm-mirror/compiler-rt#branch=release_80"
+ "git+https://github.com/CraneStation/wasi-libc"
+ "git+https://github.com/keith-packard/picolibc"
"LICENSE.llvm::https://llvm.org/LICENSE.txt"
"LICENSE.golang::https://raw.githubusercontent.com/golang/go/master/LICENSE"
)
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'f72b120d1385408e9e380acc020756eb6ba1b461d66c328ea67327ba08d7dcfd'
'2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067')
@@ -42,7 +56,17 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- git submodule update --init
+
+ git submodule init
+ git config -f .gitmodules 'submodule.lib/nrfx.url' "$srcdir/nrfx"
+ git config -f .gitmodules 'submodule.lib/CMSIS.url' "$srcdir/CMSIS"
+ git config -f .gitmodules 'submodule.lib/avr.url' "$srcdir/avr-mcu"
+ git config -f .gitmodules 'submodule.lib/cmsis-svd.url' "$srcdir/cmsis-svd"
+ git config -f .gitmodules 'submodule.lib/compiler-rt.url' "$srcdir/compiler-rt"
+ git config -f .gitmodules 'submodule.lib/wasi-libc.url' "$srcdir/wasi-libc"
+ git config -f .gitmodules 'submodule.lib/picolibc.url' "$srcdir/picolibc"
+ git submodule sync
+ git submodule update
}
build() {