summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-09-18 20:37:15 -0700
committerxiota2023-09-18 20:37:15 -0700
commit634fbc8e3abf637d7f602606180cf3b950877824 (patch)
tree3dd2c5c7ed0756449000cc787ff91d721116e443
parent627e00a451955345fff0e60d33f2e6d221a6f017 (diff)
downloadaur-634fbc8e3abf637d7f602606180cf3b950877824.tar.gz
minor changes
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5f82bb1609..35981f13abe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = tinygo-git
- pkgdesc = Go compiler based on LLVM for microcontrollers, WebAssembly, and command-line tools
+ pkgdesc = Go compiler for small places. Microcontrollers, WebAssembly, and command-line tools. Based on LLVM.
pkgver = 0.29.0.r0.gdc449882
pkgrel = 1
- url = https://tinygo.org/
+ url = https://github.com/tinygo-org/tinygo
arch = i686
arch = pentium4
arch = x86_64
@@ -24,8 +24,10 @@ pkgbase = tinygo-git
provides = tinygo
conflicts = tinygo
options = !strip
+ options = !lto
source = tinygo::git+https://github.com/tinygo-org/tinygo.git
source = git+https://github.com/espressif/llvm-project#branch=xtensa_release_15.x
+ source = llvm_build_j1.patch
source = CMSIS::git+https://github.com/ARM-software/CMSIS.git
source = avr::git+https://github.com/avr-rust/avr-mcu.git
source = binaryen::git+https://github.com/WebAssembly/binaryen.git
@@ -39,9 +41,9 @@ pkgbase = tinygo-git
source = stm32-svd::git+https://github.com/tinygo-org/stm32-svd
source = wasi-libc::git+https://github.com/CraneStation/wasi-libc
source = WASI::git+https://github.com/WebAssembly/WASI
- source = llvm_build_j1.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = a5352a32ed89120af415825fa5b73a0e7bb907fa6efaa63529ad721a53cf4844
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -55,6 +57,5 @@ pkgbase = tinygo-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = a5352a32ed89120af415825fa5b73a0e7bb907fa6efaa63529ad721a53cf4844
pkgname = tinygo-git
diff --git a/PKGBUILD b/PKGBUILD
index ee34cf8a0256..829634da3b23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname="tinygo"
pkgname="$_pkgname-git"
pkgver=0.29.0.r0.gdc449882
pkgrel=1
-pkgdesc="Go compiler based on LLVM for microcontrollers, WebAssembly, and command-line tools"
+pkgdesc="Go compiler for small places. Microcontrollers, WebAssembly, and command-line tools. Based on LLVM."
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://tinygo.org/"
license=('BSD')
@@ -30,15 +30,20 @@ optdepends=(
'arm-none-eabi-gdb: tinygo gdb support'
)
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+if [ x"$_pkgname" != x"$pkgname" ] ; then
+ provides=("$_pkgname")
+ conflicts=("$_pkgname")
-options=(!strip)
+ url="https://github.com/tinygo-org/tinygo"
+fi
+
+options=(!strip !lto)
_pkgsrc="$_pkgname"
source=(
"$_pkgname"::"git+https://github.com/tinygo-org/tinygo.git"
"git+https://github.com/espressif/llvm-project#branch=xtensa_release_15.x"
+ "llvm_build_j1.patch"
# tinygo submodules
'CMSIS'::'git+https://github.com/ARM-software/CMSIS.git'
@@ -56,12 +61,11 @@ source=(
# wasi-libc submodules
'WASI'::'git+https://github.com/WebAssembly/WASI'
-
- "llvm_build_j1.patch"
)
sha256sums=(
'SKIP'
'SKIP'
+ 'a5352a32ed89120af415825fa5b73a0e7bb907fa6efaa63529ad721a53cf4844'
# tinygo submodules
'SKIP'
@@ -79,8 +83,6 @@ sha256sums=(
# wasi-libc submodules
'SKIP'
-
- 'a5352a32ed89120af415825fa5b73a0e7bb907fa6efaa63529ad721a53cf4844'
)
pkgver() {